Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to ssh via LAN using hosts admin credentials.

I am able to login to a system using admin credentials via the Mac's GUI

I am able to ping the Mac via LAN

Sharing > Remote Login is enabled for the admin user and all options permitted.

At the Terminal prompt I would usually expect to see the following after making the request:

The authenticity of host ' (' can't be established. RSA key fingerprint is xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx. Are you sure you want to continue connecting (yes/no)

But this does not happen and the Terminal just waits for me to break the command.

I am able to ssh to all the other systems on the LAN but not this one.

What else could I be missing ?

share|improve this question
Pass ssh the -v flag so you can see how far it gets and what it's waiting for. – David Schwartz Oct 20 '11 at 16:00
@David Schwartz I get this : OpenSSH_5.2p1, OpenSSL 0.9.7l 28 Sep 2006 debug1: Reading configuration data /etc/ssh_config debug1: Connecting to [] port 22: Operation timed out – timoto Oct 20 '11 at 16:05
Okay, so it can't reach the other machine on port 22 (the SSH port). That usually indicates a firewall issue. (On either machine.) – David Schwartz Oct 20 '11 at 16:07
@David Schwartz Thanks for the pointer. So I went to the host Security > Firewall and changed it from "Allow only essential Services" to "Allow all incoming connections". This worked. But I don't want the system completely open, so I tried "Set access for specific services and applications" and this also worked. However, I would be keen to learn what OSX will actually allow and not allow if set to "Allow all incoming connections" which appears to be the default setting. – timoto Oct 20 '11 at 16:43
up vote 1 down vote accepted

As the comments now show, the firewall was blocking incoming connections on port 22.

Setting the firewall to "allow all incoming connections" will do just that, no inbound TCP connections will be blocked.

share|improve this answer
Thank you David. – timoto Oct 20 '11 at 19:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .