Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a TP-Link TL-WN727N which I use to create an access point for my Android phone to connect to.

In Device Manager, I can enable "Adhoc support 802.11n" and it'll work in 802.11n, however Android phones have a hard time connecting to them.

Creating a soft AP either from command line (netsh wlan set hostednetwork mode=allow ...) or with Connectify will work, and the phone can connect to it, however it is only 802.11b with a max speed of 54 Mbps.

The output of netsh wlan show hostednetwork is:

Hosted network settings
-----------------------
    Mode                   : Allowed
    SSID name              : "Police Surveillance Van"
    Max number of clients  : 20
    Authentication         : WPA2-Personal
    Cipher                 : CCMP

Hosted network status
---------------------
    Status                 : Started
    BSSID                  : f4:ec:38:98:83:60
    Radio type             : 802.11b
    Channel                : 1
    Number of clients      : 1
        cc:f9:e8:86:ec:c4        Authenticated

I didn't find any way to change radio type or the channel. Googling around revealed some other dumps, which had 802.11n as the radio type, so it's possible somehow.

The XML file exported by netsh wlan export hostednetworkprofile supports setting the radio type, since it has a <phyType> tag, according to its docummentation. However, this is not set on the file exported for me.

share|improve this question

2 Answers 2

I'm not having any luck either after plenty of hours trying. I've managed to get couple pings randomly through to the phone's IP that's it, it shows up in arp -a after all.

Your wireless uses RU3070 I believe. Mine is rtl8192u. Driver docs claim Win7 softap is supported and it all appears to work except the phone doesn't get the ICS 137 IP fast every time and when it has obtained the IP, nothing works.

I'd love to know if anyone has Android (Samsung Gio here w/ 2.3.3) working with Win7 with SoftAp / Virtual Wifi using ICS, so you can use a single usb wifi adapter to both obtain internet access and share it to the phone.

I'll have to get another 802.11n adapter to see if the Soft AP works to another windows computer, this would help finding if the problem is the phone or the current adapter/drivers I have.

Just for reference, my rtl8192u has a public ipv4 interface (public ipv4 ip) and I'm trying to have the SoftAp to work with it, so the Windows ICS will essentially firewall & NAT the ipv4 interface over to the SoftAp. Sounds bit complicated but that's how this thing should work and it'll be great to get it working.

All the devices are 802.11n and since arp and even ping sometimes do work, it could be incompatibility with Win7 SoftAP and something in the phone.

share|improve this answer

You can change the protocol for most wireless adapters by bringing up the device manager, opening the properties for the wireless adapter and selecting the "Advanced" tab. The "Wireless Mode" setting on the left lets you choose between b/g/n.

share|improve this answer
    
A hostednetwork shows up under the device manager as "Microsoft Virtual Wifi Miniport Adapter" and does not have an Advanced tab. –  Matthieu Cormier Dec 19 '12 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.