Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I"m trying to update my Ubuntu, and previously my internet connection went out when trying to update, now all i get is this error message:

Package operation failed

The installation or removal of a software package failed.

EDIT: error:

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/main/binary-     i386/Packages  Could not open file /var/lib/apt/lists/partial/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages - open (28: No space left on device) [IP: 74.125.224.68 80]

Note, i have over 5gb left on the disk...

Error code after running:

sudo apt-get dist-upgrade

(Reading database ... 176208 files and directories currently installed.) Preparing to replace tzdata-java 2011k-0ubuntu0.11.04 (using .../tzdata-java_2011l-0ubuntu0.11.04_all.deb) ... Unpacking replacement tzdata-java ... dpkg: error processing /var/cache/apt/archives/tzdata-java_2011l-0ubuntu0.11.04_all.deb (--unpack): unable to create /usr/share/javazi/Pacific/Tarawa.dpkg-new' (while processing./usr/share/javazi/Pacific/Tarawa'): No space left on device No apport report written because the error message indicates a disk full error dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Preparing to replace tzdata 2011k-0ubuntu0.11.04 (using .../tzdata_2011l-0ubuntu0.11.04_all.deb) ... Unpacking replacement tzdata ... dpkg: error processing /var/cache/apt/archives/tzdata_2011l-0ubuntu0.11.04_all.deb (--unpack): unable to create /usr/share/zoneinfo/Pacific/Yap.dpkg-new' (while processing./usr/share/zoneinfo/Pacific/Yap'): No space left on device No apport report written because the error message indicates a disk full error dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/tzdata-java_2011l-0ubuntu0.11.04_all.deb /var/cache/apt/archives/tzdata_2011l-0ubuntu0.11.04_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

share|improve this question
1  
Can you give more details as to this error? This is VERY general here. –  Simon Sheehan Oct 20 '11 at 22:29
1  
try sudo apt-get update –  Paul Oct 20 '11 at 22:44
    
it just seems to donwnload files and not do anything... –  hagope Oct 21 '11 at 17:31
    
update won't do anything itself, other than update what you need to upgrade. Now do a sudo apt-get dist-upgrade –  Rob Oct 21 '11 at 17:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.