Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set Bacula up a few days ago, and everything seemed fine. I noticed today that jobs were failing, and upon investigation, it looks like bacula-sd is just not listening on the port it should be listening on. The daemon is running, but netstat -nlap | grep bacula turns up nothing.

It worked fine before, and nothing really changed as far as I know. I tried straceing it as it started, but nothing jumped out. It hasn't written anything to, or even created, /var/log/bacula/log. How can I make bacula-sd start listening?

share|improve this question
    
Being sick sucks. I retyped your chat conversation for you. FYI there was a place where you said "nestat" and I assumed you meant "netstat" and changed it. –  Pops Oct 21 '11 at 22:05
    
thanks! :) <fifteen characters> –  Personman Oct 26 '11 at 21:21

1 Answer 1

Do you have the director running on a different machine? Since you didn't see the director or file daemon show up when you ran netstat I'm thinking that the service isn't running. If for some reason the daemons fail to run I would run each of the daemons from the command line with the -t and -c switches to check the config files for errors.

bacula-sd -t -c [path the bacula-sd.conf]
bacula-fd -t -c [path the bacula-fd.conf]
bacula-dir -t -c [path the bacula-dir.conf]
share|improve this answer
    
The director and fd are running on a different machine. Only the sd runs on this machine, and it is definitely running, but not listening. –  Personman Oct 26 '11 at 21:19
    
I'm thinking at this point you might need to start bacula-sd from the command line with the -f switch and maybe some others (-d ##, -v) to run it in the foreground and look for any issues. You may also want to check if something else is using port 9103. –  chuck Nov 7 '11 at 14:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.