Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not really sure how to ask this properly so I'll try to describe the best I can. There's a layer which has its blending set to 'overlay' and its opacity set to 83%.

Normally to copy a transparent layer, I created a merged copy of the document (shift-option-command E) and then create the selection from the layer having the transparent item, and copy from the merged layer.

However, when doing this with a layer that's got a blending mode, it doesn't seem to select everything properly (the area, which is a highlight, ends up much smaller).

Any suggestions here? Or any information I can provide to make answering easier?

share|improve this question
    
Add this info: Is the blended layer soft, like a soft-edged brush stroke, or something similar? And are you judging "smaller" by the marching ants, or by what you actually copy off of it and paste somewhere else? –  Alan Gilbertson Sep 28 '11 at 3:30
2  
I'm kind of lost in what the exact situation is.. But, right now i see no reason why you couldnt use Ctrl+J or right click the layer and select Duplicate layer.. from the list. –  Joonas Sep 28 '11 at 6:22
    
@Lollero because its a got a blending mode, the things underneath it affect how it appears. I need to keep the coloration it gets from the things underneath it without copying anything underneath it (it needs to be turned into a .png) –  Sloop Sep 30 '11 at 12:08
    
So the point is.. You want to save that layer as transparent png that still has the effect you've set with blending options? –  Joonas Sep 30 '11 at 12:19
add comment

migrated from graphicdesign.stackexchange.com Oct 21 '11 at 21:55

This question came from our site for professional graphic designers and non-designers trying to do their own graphic design.

1 Answer

In the absence of further information, I suspect you're running into the fact that selection is based on the opacity of the pixels. With a layer that is soft edged, the degree of selection will be reduced based on the opacity of the edge pixels, which fade into transparency. Then, when you copy, the amount of "copy" is based on the degree of selection, so you get a sort of double reduction in "selectedness" that leaves you with an object smaller than the one you started with.

The solution is to simply copy the layer a few times (Ctl-J). The pixels on each layer build on the ones below, so you will see the image grow to the right size as you build the opacity. When you have it the way you want it, select all these layers and merge (Ctl-E).

It's counter-intuitive, I know, but that's just the way Photoshop works with transparency.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.