Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I took out the hard drive from my Dell Latitude E5420 notebook, put in an ADATA S599 solid state drive, and installed Ubuntu 11.10.

When I boot, the Dell BIOS splash screen appears with a progress bar, which quickly fills up, and the screen goes black. All of this is like it was before. At this point, the OS splash screen should fade in. Instead, I was dismayed to see simply the following, in white text on a black screen:

No boot device found. Press any key to continue

After looking around for the Any key (just kidding) I press a key, and the Dell BIOS splash screen appears again with a progress bar, which quickly fills up, and the screen goes black. This time, however, the Ubuntu splash screen shows up, Ubuntu opens up, and all is normal.

Every time I shut down, however, this happens again. It's like a game the computer and I play together. The computer has never started up without first saying:

No boot device found. Press any key to continue

and it has always started up after I press any key to continue.

It also starts up fine if I click Restart instead of Shut Down. Thoughts?

share|improve this question

migrated from serverfault.com Oct 22 '11 at 1:29

This question came from our site for system and network administrators.

    
Close enough, AHCI :) –  Shane Madden Oct 22 '11 at 0:28
    
Did you check you default boot drive in the BIOS? Since removing the default hard drive the default boot drive setting would be lost. –  cybernard Apr 7 '13 at 1:58

1 Answer 1

Change between the RAID and AHCI mode in the BIOS.

share|improve this answer
1  
Thank you, that worked but caused my DVD drive to disappear. In my BIOS, SATA Operations has three choices: Disabled, ATA, and AHCI. AHCI was chosen. I changed it to ATA, and the boot errors disappeared. But now when I pop in a CD or DVD the OS never mounts them. The DVD-ROM drive doesn't even appear in the /dev directory anymore (it used to be /dev/sr0) –  Andrew Banks Oct 25 '11 at 16:54
    
@AndrewBanks: Hmm, tricky. I'm not good enough in Linux to knaw that... –  Tom Wijsman Oct 25 '11 at 17:03
    
@AndrewBanks boot another OS (LiveCD or something) and check if it sees your drive. Also, do you have latest BIOS version? –  gronostaj Mar 12 '13 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.