Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows XP SP3 logged in as the administrator.

I had RAID Mirroring running. The motherboard broke earlier in the year. When I got a new battery I did not resync. I just use the disks as two separate disks.

I searched Google for the errors but I didn't find anything detailed enough.

The following Microsoft components are in Add/Remove programs:

  • .NET Framework 1.1
  • .NET Framework 2.0 Service Pack 2
  • .NET Framework 3.0 Service Pack 2
  • .NET Framework 3.5 SP1
  • Microsoft Compression Client Pack 1.0 for Windows XP
  • Microsoft Office Enterprise 2007
  • Microsoft Silverlight
  • Microsoft USB Flash Driver Manager
  • Micrsoft User-mode Driver Framework Feature Pack 1.0
  • Microsoft Visual C++ 2005 ATL Update KB 973923 x86 8.050727.4053
  • Microsoft Visual C++ 2005 Redistributable

This is the installation log:

Exists: evaluating...

[10/21/2011, 22:17:14]MsiGetProductInfo with product code {3C3901C5-3455-3E0A-A214-0B093A5070A6} found no matches

[10/21/2011, 22:17:14] Exists evaluated to false

[10/21/2011, 22:15:50]calling PerformAction on an installing performer
[10/21/2011, 22:15:50] Action: Performing actions on all Items...

[10/21/2011, 22:15:50]Wait for Item (clr_optimization_v2.0.50727_32) to be available
[10/21/2011, 22:15:50]clr_optimization_v2.0.50727_32 is now available to install
[10/21/2011, 22:15:50]Creating new Performer for ServiceControl item
[10/21/2011, 22:15:50] Action: ServiceControl - Stop clr_optimization_v2.0.50727_32...

[10/21/2011, 22:15:50]ServiceControl operation succeeded!

[10/21/2011, 22:15:50] Action complete

[10/21/2011, 22:15:50]Error 0 is mapped to Custom Error: 
[10/21/2011, 22:15:50]Wait for Item (Windows6.0-KB956250-v6001-x86.msu) to be available
[10/21/2011, 22:15:51]Windows6.0-KB956250-v6001-x86.msu is now available to install
[10/21/2011, 22:15:51]Created new DoNothingPerformer for File item
[10/21/2011, 22:15:51]No CustomError defined for this item.
[10/21/2011, 22:15:51]Wait for Item (Windows6.1-KB958488-v6001-x86.msu) to be available
[10/21/2011, 22:15:51]Windows6.1-KB958488-v6001-x86.msu is now available to install
[10/21/2011, 22:15:51]Created new DoNothingPerformer for File item
[10/21/2011, 22:15:51]No CustomError defined for this item.
[10/21/2011, 22:15:51]Wait for Item (netfx_Core.mzz) to be available
[10/21/2011, 22:15:52]netfx_Core.mzz is now available to install
[10/21/2011, 22:15:52]Created new DoNothingPerformer for File item
[10/21/2011, 22:15:52]No CustomError defined for this item.
[10/21/2011, 22:15:52]Wait for Item (netfx_Core_x86.msi) to be available
[10/21/2011, 22:15:52]netfx_Core_x86.msi is now available to install
[10/21/2011, 22:15:52]Creating new Performer for MSI item
[10/21/2011, 22:15:52] Action: Performing Action on MSI at F:\DOCUME~1\Owner\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_4.0.30319\netfx_Core_x86.msi...

[10/21/2011, 22:15:52]Log File F:\DOCUME~1\Owner\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_20111021_221545515-MSI_netfx_Core_x86.msi.txt does not yet exist but may do at Watson upload time
[10/21/2011, 22:15:52]Calling MsiInstallProduct(F:\DOCUME~1\Owner\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_4.0.30319\netfx_Core_x86.msi, EXTUI=1
[10/21/2011, 22:17:14]MSI (F:\DOCUME~1\Owner\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_4.0.30319\netfx_Core_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20111021_221545515-MSI_netfx_Core_x86.msi.txt
[10/21/2011, 22:17:14]PerformOperation returned 1603 (translates to HRESULT = 0x80070643)

[10/21/2011, 22:17:14] Action complete

[10/21/2011, 22:17:14]OnFailureBehavior for this item is to Rollback.
[10/21/2011, 22:17:14] Action: Performing actions on all Items...

[10/21/2011, 22:17:14] Action complete

[10/21/2011, 22:17:14] Action complete

[10/21/2011, 22:17:14]Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:29).
[10/21/2011, 22:17:41]WM_ACTIVATEAPP: Focus stealer's windows WAS visible, NOT taking back focus

SECOND LOG REQUESTED BELOW:

MSI (s) (6C:EC) [22:17:13:828]: Invoking remote custom action. DLL: F:\WINDOWS\Installer\MSIBB4.tmp, Entrypoint: NgenUpdateHighestVersionRollback
MSI (s) (6C:64) [22:17:13:984]: Executing op: ActionStart(Name=CA_NgenRemoveNicPFROs_I_DEF_x86.3643236F_FC70_11D3_A536_0090278A1BB8,,)
MSI (s) (6C:64) [22:17:13:984]: Executing op: ActionStart(Name=CA_NgenRemoveNicPFROs_I_RB_x86.3643236F_FC70_11D3_A536_0090278A1BB8,,)
MSI (s) (6C:64) [22:17:13:984]: Executing op: CustomActionRollback(Action=CA_NgenRemoveNicPFROs_I_RB_x86.3643236F_FC70_11D3_A536_0090278A1BB8,ActionType=17729,Source=BinaryData,Target=NgenRemoveNicPFROs,)
MSI (s) (6C:AC) [22:17:13:984]: Invoking remote custom action. DLL: F:\WINDOWS\Installer\MSIBB5.tmp, Entrypoint: NgenRemoveNicPFROs
MSI (s) (6C:64) [22:17:14:000]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=0)
MSI (s) (6C:64) [22:17:14:000]: Error in rollback skipped.  Return: 5
MSI (s) (6C:64) [22:17:14:015]: No System Restore sequence number for this installation.
MSI (s) (6C:64) [22:17:14:015]: Unlocking Server
MSI (s) (6C:64) [22:17:14:015]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.
MSI (s) (6C:64) [22:17:14:031]: Note: 1: 1708 
MSI (s) (6C:64) [22:17:14:031]: Product: Microsoft .NET Framework 4 Client Profile -- Installation failed.

MSI (s) (6C:64) [22:17:14:078]: Cleaning up uninstalled install packages, if any exist
MSI (s) (6C:64) [22:17:14:078]: MainEngineThread is returning 1603
MSI (s) (6C:EC) [22:17:14:171]: Destroying RemoteAPI object.
MSI (s) (6C:9C) [22:17:14:171]: Custom Action Manager thread ending.
MSI (c) (F4:C4) [22:17:14:203]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (F4:C4) [22:17:14:203]: MainEngineThread is returning 1603
=== Verbose logging stopped: 10/21/2011  22:17:14 ===
share|improve this question
add comment

2 Answers

You can use the .NET Framework Cleanup Tool to obliterate all traces of the .NET Framework from your computer and try installing it again.

This .NET Framework cleanup tool is designed to automatically perform a set of steps to remove selected versions of the .NET Framework from a computer. It will remove files, directories, registry keys and values and Windows Installer product registration information for the .NET Framework. The tool is intended primarily to return your system to a known (relatively clean) state in case you are encountering .NET Framework installation, uninstallation, repair or patching errors so that you can try to install again.

The user's guide carries an important warning:

This tool is designed as a last resort for cases where install, uninstall, repair or patch installation did not succeed for unusual reasons. It is not a substitute for the standard uninstall procedure.

share|improve this answer
    
And given the cancerous nature with which .NET Framework installs itself into Windows XP, if the cleanup tool does not work at fixing it, it's an OS wipe and reload. Been there... –  Fiasco Labs Dec 7 '13 at 19:47
add comment
  1. First have a look at the log file F:\DOCUME~1\Owner\LOCALS~1\Temp\Microsoft .NET Framework 4 Client Profile Setup_20111021_221545515-MSI_netfx_Core_x86.msi.txt for more information.

  2. Try clearing the TEMP folder. Then restart the installation.

share|improve this answer
    
ill look at the temp folder. I cant post much of the log here. –  Bob Oct 22 '11 at 12:34
    
MSI (s) (6C:64) [22:17:14:000]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=0) MSI (s) (6C:64) [22:17:14:000]: Error in rollback skipped. Return: 5 MSI (s) (6C:64) [22:17:14:031]: Note: 1: 1708 MSI (s) (6C:64) [22:17:14:078]: MainEngineThread is returning 1603 –  Bob Oct 22 '11 at 12:37
    
sorry about pasting above. i added teh end to the log requested by Ganesh to the end of my original question. –  Bob Oct 22 '11 at 12:45
    
sorry about all the posts. I deleted my entire temp directory on both hard drives and got the exact same error. –  Bob Oct 22 '11 at 13:15
    
@Bob The error you mentioned was faced by someone else. See social.msdn.microsoft.com/Forums/en/netfxsetup/thread/… He mentioned it was a privilege problem. Are you a full administrator on the machine? Can you try installing it with built-in "Administrator" account or another Admin account. –  Ganesh R. Oct 22 '11 at 13:40
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.