Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open Firefox (8 Beta and 7) and load a page with firebug open, I get a load of javascript strict warnings, so I disable javascript strict warnings so my page loads will speed up, which works until I restart Firefox. Every time I open Firefox, javascript strict warnings are enabled. I even tried turning them off through the about:config settings.

Any ideas on how to keep it off so I don't have to disable strict warnings every time I open Firefox?

share|improve this question
    
about:config > javascript.options.strict.debug or javascript.options.strict ?? –  rlemon Oct 22 '11 at 3:38
    
Tried those as well. strict.debug is set to false and strict will toggle to false, but when I restart the browser, it's always set to true. –  Francis Oct 22 '11 at 8:35
1  
Have you tried running in safe mode / in new profile? I guess this behavior might be related with some extension, perhaps JavaScript-related extensions. Look in their configuration thoroughly. –  jakub.g Oct 22 '11 at 20:59
    
I disabled all the extensions I had installed, then started enabling them in sets and narrowed it down till I found every time I had PDF Download disabled, Javascript strict errors were disabled. Every time PDF Download was enabled, Javascript strict errors were enabled. So I'm keeping that extension disabled. Thanks for the suggestion! I certainly wouldn't have pegged PDF Download to be the one. I figured maybe any number of CSS or Javascript editors/debuggers I had. –  Francis Oct 25 '11 at 17:29

2 Answers 2

In about:config, set this option to false:

extensions.firebug.showJSWarnings
share|improve this answer

Go to about:config, and set javascript.options.strict to false.

If you run Firefox using the cfx tool (of the Addon SDK), then this will not help because the Addon SDK forces this preference to be true on start-up. To fix this, locate the directory containing the Addon SDK, open python-lib/cuddlefish/prefs.py and change

    'javascript.options.strict': True,

to

    'javascript.options.strict': False,

If you are bothered by deprecation warnings to the extent that they are not helpful (e.g. because you are a web developer that uses third-party libraries that are not going to be patched), then disable the warnings by setting devtools.errorconsole.deprecation_warnings to false at about:config.

share|improve this answer
    
devtools.errorconsole.deprecation_warnings doesn't remove all the warnings. In particular, it doesn't remove the one caused by AdBlock. –  romkyns Aug 26 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.