Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have had a working setup for 3 weeks which suddenly stopped working this morning. I can't identify what changed. I have two network interfaces on my main (Ubuntu 10.10) PC; eth0 is an ethernet card connected to the Internet and eth1 is a USB network interface which I connect to my laptop. I bridge eth0 and eth1 so all my laptop's internet traffic goes through my main PC (university network).

Last night this worked perfectly. This morning eth1 does not appear when I do 'ifconfig'. Also in the gnome network manager the usb adapter (eth1) is greyed out. When I run 'sudo ifconfig eth1 up' I get 'SIOCSIFFLAGS: Cannot assign requested address'. When I run 'sudo ifconfig eth1 192.169.0.1' I get the same.

I also noticed that when I run 'sudo lspci' there is no mention of an ethernet interface at all (both connections I'm using are ethernet and eth0 works fine).

Could anyone suggest how I should go about troubleshooting this?

Thanks!

Edit: I can also ping 192.168.0.1 (eth1) and I get a reply

share|improve this question

For some reason the mac address had been assigned to 00.00.00.00.00. I found this out by doing "dmesg | grep eth1"

The fix was: sudo ifconfig eth1 hw ether

I found the mac address by looking in the gnome networking config... luckily it was there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .