Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(This seems similar to an issue in "Vista Internet connection stops working until reboot" but has quite a few differences, so I'm posting it separately.)

I have Windows Vista Home Premium.

With alarming regularity, any and all http requests simply die. I can't find any rhyme or reason for it. It can happen 20 minutes after I start my browsing session, or two hours.

My network connection does not go down, and no other protocols seem to be affected. (I can connect to WoW, can use POP and IMAP, DropBox continues to update files, etc.) I can still ping website addresses, but the browser simply refuses to connect.

More unusually, it kills it for all browsers. If I'm using Firefox and it dies, then start up Chrome, Safari, or IE, none of them can load any pages either. The loading indicator just "spins" forever. AJAX HTTP calls are similarly affected. (Gmail doesn't update while I'm in this state, for instance.) Only a restart has been effective in clearing it.

I'm connecting through a Linksys router, but none of the other PCs (Win XP and Linux) on my network are experiencing this issue. Only the Windows Vista machine is so affected.

I'm hanging on for Windows 7, but am afraid that it won't fix the issue. I am religious about keeping the OS and software up-to-date with patches.

How can I fix this? What should I be looking at?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I would guess that it's probably your anti-virus software or firewall. As wil said, you should also check your proxy settings. This may be strange, but I've noticed that the StumbleUpon toolbar will make my http requests time out. I try using different browsers, and the http requests still time out. But, when I disable the StumbleUpon toolbar, then there are no more timeouts.

share|improve this answer
    
It appears that Zone Alarm Pro was the culprit. Disabled it, then later replaced it with Comodo Firewall and I have enjoyed hours of trouble-free websurfing. I'm kicking myself for not seeing it myself, since this was the only machine I have using ZA. As to why it was doing it I'm baffled still; there was nothing in any logs I saw. I'm optimistic that this is it. –  Al E. Sep 5 '09 at 5:36

First things to take a look -

Firewalls, Anti-virus, Anti-Malware....

Development tools? Fiddler, or any other proxy server...

Check your proxy settings in general.

Personally, I would install Wfetch and see if I get any luck.

Also, if you have any Virtualisation software, installed do you get the same problems from browsing the internet in them?

Lastly, go in to safe mode with networking and try again and see if you still have the problem.

share|improve this answer
    
I have tried with and without anti-virus and firewall running, but I'll do it again and confirm. No development tools on here, nor virtualization software. It's a pretty vanilla setup. –  Al E. Sep 3 '09 at 16:58

Does everything appear normal on your (wireless) connection details?

Is your DNS pointing to a real address?

I've had similar on Win7 that I'm trying to peg down the cause. But I believe that DNS the principle cause. I'm interested for selfish reasons on how this will play out. ... I was able to access sites over port 80 again after I disconnected and reconnected from the network, but I started out with restarts which also worked. Likewise other machines on the network are not affected.

share|improve this answer
    
DNS is pointing to the router. I hadn't considered a DNS issue, and this is a wired connection. I'll see if disconnecting/reconnecting to the network helps. –  Al E. Sep 3 '09 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.