Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I bought an Internet radio: a box with speakers, built-in CD player and FM tuner, Ethernet connector, WiFi antenna etc. It's a new model, released about 6 months ago. When I try to set it up, whether with WiFi or Ethernet, it freezes up on the "Connected" screen. (I have another internet radio made by a different manufacturer (Aluratek) and it works just fine, but does not play .flac files which is one reason why I bought the new one.)

I returned it and got a different unit. Same problem. The manufacturer (a large Korean company) offers no tech support at all, but I found a small sales office in California. The sales manager was helpful. I sent the unit to him and he found that it ran just fine on his network. He sent it back. It still doesn't work for me.

That exhausts all the manufacturer's tech support options, as far as I can tell. Maybe it's incompatible with the router, but I tried it with my old non-WiFi router over Ethernet and had the same problem. Maybe it's incompatible with my cable service or cable modem. I don't think I'll have any luck getting Linksys (Wifi router), Motorola (cable modem) or Charter (cable ISP) tech support to help me at all.

I know that it acquires an address from DHCP. I can see the negotiation in the router's DHCP log. Maybe it is making a synchronous request that is not getting a response and freezing. (It's not the time-setting function -- I went through the set-up and disabled the automatic time-setting, and it still froze up.)

How can I diagnose this? When I run a program on my computer that has network problems I open TcpView to look at the connections. Is there anything similar I can do when the problem is in a self-contained appliance with no known diagnostics?

(The only reason I didn't buy a Tivoli instead is because the Tivoli, like the Aluratek, does not play .flac files.)

share|improve this question

migrated from Oct 23 '11 at 18:22

This question came from our site for system and network administrators.

Did you try maunally configuring an address , subnet, gateway, and dns on the device itself? – Psycogeek Oct 23 '11 at 19:21
I tried various options to the extent that the device allowed it in the menus. I know the DHCP server in the router issued an IP address. Presumably it also provided subnet, gateway and DNS, as it has for every computer and other device I have used. The device doesn't appear to offer much in the way of diagnostics to manually examine this. – Mark Lutton Oct 23 '11 at 20:20
Maybe your ISP is blocking some port that the Radio needs? Try using Wireshark. It's the industry standard for network troubleshooting, it works like TCPView but monitors every package that passes by instead of just the endpoints on your computer. – micke Oct 23 '11 at 22:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.