Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Everything connected to WRT54GL wired network is accessing the net correctly. I have disabled the wireless on this router since it's in a deep corner of the house. I placed a centrally located WRT54GS router to act as a wireless access point, but it will not connect to the net (or give an IP address for that matter). The two routers are connected by their respective ethernet ports (not WAN/"Internet") with a powerline ethernet adapter.

On the access point (WRT54GS), I have tried several things, and combinations of them all: - Changing the IP address to not be identical as the router - Disabling DHCP - Enabling DHCP with a range outside that of the router

I'm sorry if this had been answered previously, but I did search exhaustively for most of the day. Your help is greatly appreciated.

Brandon

UPDATE: DD-WRT has been installed (which I don't mind, I've always wanted to try it). But, after Journeyman Geek's suggestion, it appears it is in fact the powerline adapter. The WAP works as expected when plugged directly into the router, but does not when through the powerline (Netgear XAV101v2). Any ideas?

ADDENDUM: For anyone with this problem in the future, I downloaded a configuration utility from Netgear's support page. I used it to factory reset the PLA, and upgrade the firmware. The WAP is now working great, through the PLA in it's new location. I now have wifi in every corner of the house. Thanks again everyone for your help.

share|improve this question
    
i'm a little confused by your network topology - is it modem -> wrt54g -> wrt54gs? –  Journeyman Geek Oct 23 '11 at 23:54
    
It's more like: modem->vonage hardware->WRT54GL->WRT54GS –  Brandon Condrey Oct 24 '11 at 0:01

2 Answers 2

up vote 0 down vote accepted
                                      Clients
                                        ^
                                        |
                                        |
                                        |
                                        +
              +--------+          +---------+
 Modem+-----> |Router 1|          |Router 2 |
              |DHCP on +--------> |No DHCP  |
              +--------+          |Static IP|
                   +              +---------+
                   |
                   |
                   |
                   v


                clients

Works

                                      Clients
                                        ^
                                        |
                                        |
                                        |
                                        +
              +--------+          +---------+
 Modem+-----> |Router 1|          |Router 2 |
              |DHCP on +--+   +-> |No DHCP  |
              +--------+  |   |   |Static IP|
                   +      |   |   +---------+
                   |      |   |
                   |      |   |
                   |      |   |
                   v      |   |
                          |   |
                          |   |
                clients   +---+
                         PLA  PLA

Does not

Since substituting router 2 with a computer doesn't work, the issue is probably with the power line adapters.

I'd try it with the two adaptors in adjacent sockets (to rule out them being on separate circuits) , and if that fails, probably look up the documentation to see if they need any configuration to work.

share|improve this answer
    
Thanks again. I like your fancy diagram by the way. I'm on the hunt for a new powerline adapter I guess (or a very long, incognito cat5 cable). –  Brandon Condrey Oct 24 '11 at 3:43
1  
i use a website called ASCIIflow for that –  Journeyman Geek Oct 24 '11 at 3:49
    
+1 for the ASCIIFlow link! –  rossmcm Jul 8 '13 at 4:37

Best would be to

  • Disable DHCP server in access point (so he doesn't distribute IPs)
  • Can you setup your access point to a mode like "bridge" or "access point", so it loses its routing functions? You don't need them.
  • Setup some static IP outside the DHCP-range of your router on your access point

Now connect to your access point. Does it offer some possibility to ping your router? Can you ping your router directly? If you plugin your computer into the powerline adaptor (instead of your access point), are you able to ping your router?

If your access point is of hardware revision 4 or less, think about flashing DD-WRT - it offers much more possibilites to reconfigure your router to an access point, and there's some tutorial for doing this. Maybe even think about switching your router and access point as the WRT54GL can be flashed to DD-WRT for sure.

share|improve this answer
    
all GLs support DD-wrt - they're basically the v4 model being sold with a different name, and at a premium for people who want it over the newer ones, which have smaller memory –  Journeyman Geek Oct 23 '11 at 23:55
    
That's why I want him to switch his routers. Not all GS are DD-WRT-capable. –  Jens Erat Oct 24 '11 at 0:00
    
Thanks, I'm looking into DD-wrt now. They do support the GS, I just need to figure out how to install it. –  Brandon Condrey Oct 24 '11 at 0:02
    
@BrandonCondrey - you probably don't need DD-WRT firmware. Most wireless routers can be used as an AP by simply disabling DHCP and assigning a static IP address (outside the allocatable range) to the LAN side. It can be that simple. If you still have issues then you had better explain completely your network setup. E.G. where is your DHCP server, is it the vonage box? How is the WRT54GL setup? –  sawdust Oct 24 '11 at 1:10
    
I'd start by giving the GS a static IP, turning off DHCP on it, and plugging it straight into the GL to make sure the issue isn't with the powerline ethernet adaptor part of the set up, prolly cause i know your setup looks otherwise similar to what i used to use –  Journeyman Geek Oct 24 '11 at 1:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.