Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got my webpage running yesterday, but some how when i tried to connect external i get a (111) Connection refused. I have port forwarding on 8080, and it is working perfectly internally.

I have tried change the port to 80, 8080, 8081, 443 but with out luck. I use a Netgear router and there are no port blocking on it.

I can connect to my NAS externally by portforwarding.

share|improve this question
    
did you restart apache in between changing ports? Also, see if there's a DMZ mode and put your system in it to check if it works then. Also, what is the external port you are using? –  Journeyman Geek Oct 24 '11 at 8:03
    
Apache are running on my computer through Eclipse. I have tried restart, with no help. I tried to use the DMZ and set the IP to my computers IP. I am using port 8080. I tried to use a different port-forwarding to 443, but that is not working at all. –  boje Oct 24 '11 at 8:24
    
Picture of what can be the problem: link –  boje Oct 24 '11 at 8:32
    
why is apache running through eclipise? also, looks like port 8080 is used by the router. test it with an arbitrary port first - i like 9180 –  Journeyman Geek Oct 24 '11 at 8:50
    
I have tried port "9180" but with out luck. I use Eclipse to programm, in i start the stop the server through the program. I have tried with another computer and go to external-ip:8080/hello.jsp and it works when we are on same router. It is only externel i get problems. –  boje Oct 24 '11 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.