Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded the OS on my Sony VAIO laptop from Windows Vista to Windows 7 but now my built-in camera and microphone no longer work. I've checked Device Manager but it seems they are not there, nor can I see anything in the BIOS.

Any ideas how to fix this?

share|improve this question
    
It seems they are not there? This would mean that your upgrade completely deactivatet the hardware, which is near to impossible. Check the device manager again, the devices may have strange names or be in the wrong category. You can also try to install the drivers anyway. –  Michael K Oct 24 '11 at 8:25
    
I thought about that also Michael but still cant find them. I ended up buying new camera with mic until I solve this problem. I would really love to fix it and I will download the drivers from SONY VAIO website. I haven't done that yet. Thank You very much for your help Michael. –  miladinoski Oct 24 '11 at 14:12

1 Answer 1

up vote 0 down vote accepted

Look on the Sony website for updated Windows 7 drivers for your Laptop, sometimes Windows will install additional devices as defaults... For example a USB port bridge, when it is a completely different type of interface. Once the interface has the correct driver installed Windows will usually detect other devices which use the interface for communication.

share|improve this answer
    
That is exactly what am gonna do. Thank you HaydnWVN. –  miladinoski Oct 24 '11 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.