Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
WIndows 7 cannot boot - bootrec reports FS not found or corrupt

I have 3 disks: On disk 1 I have Windows 7 installed. Disk 2 is for storage. Disk 3 was unused until I installed Ubuntu on it a couple of minutes ago.

After Ubuntu installation was complete I rebooted and tried to load Windows again. All I got was an error message saying:

reboot and select proper boot device

Windows refuses to boot for some reason. I am able to mount the Windows disk inside Ubuntu and explore its contents. All looks fine. I've tried boot override via BIOS without luck. No matter what I try I can't seem to get the Windows disk to boot. Only Ubuntu works...

Any ideas?

Update
Found this: WIndows 7 cannot boot - bootrec reports FS not found or corrupt

And I have the exact same problem. Will probably just give up, format and reinstall :(

share|improve this question

marked as duplicate by Tom Wijsman, techie007, 8088, Simon Sheehan, studiohack Nov 10 '11 at 16:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You probably damaged your MBR when you installed Ubuntu. Do you have your Windows 7 install media? –  Chris Ting Oct 24 '11 at 11:38
    
Ah. Yes, I have USB drive I installed with. –  o01 Oct 24 '11 at 11:42
    
Do you try to boot your computer and the error message appears without you selecting anything? Do you get the chance to boot Windows 7 from a menu? –  Chris Ting Oct 24 '11 at 11:50
    
Also, do you want to get your computer back to the state it was in before installing Ubuntu, or get it working with Windows 7 and Ubuntu? –  Chris Ting Oct 24 '11 at 11:55
    
I am able to select which disk I want to boot. If I select any other disk than where I installed Ubuntu, I get error message. –  o01 Oct 24 '11 at 11:57
show 1 more comment

3 Answers

Just in case it is of value to you or anyone else that happens along. There is an official page of suggestions from Ubuntu that should be entered into the record, it can be found at
https://help.ubuntu.com/community/WindowsDualBoot
It may or may not answer this specific situation.
Another of interest may be http://ubuntuguide.org/wiki/Ubuntu:All#Dual-Booting_Windows_and_Ubuntu

share|improve this answer
add comment

You need to boot from the drive where Ubuntu is installed. Then you need to open your grub menu by pressing esc within 3 seconds of boot start. They make the menu invisible by default.

From that menu, select to start your Windows OS. That should get you running.

If that doesn't work, you'll need to fix the MBR. You'll need to boot your computer from your install media, select the repair option, and then run the bootsect.exe utility. This website gives you all the screen grabs you'll need to get your Windows 7 MBR working again. http://www.sevenforums.com/tutorials/20864-mbr-restore-windows-7-master-boot-record.html

Explanation below.

When you installed Ubuntu, you installed Ubuntu's boot loader known as grub. If you follow all the defaults when you install, then grub will overwrite your Window's MBR and Windows will no longer boot on its own. You can prevent grub from touching your MBR by telling grub to install itself on the first sector of the Ubuntu drive. You could also disconnect your other drives before installing Ubuntu. A third option is to run Ubuntu virtualized from Windows using something like Virtualbox.

share|improve this answer
    
I've just tried everything in this post without success: superuser.com/questions/338128/… –  o01 Oct 24 '11 at 12:43
    
Are you saying that you followed the link in your comment, and the bootrec /FixBoot command didn't work for you? –  Chris Ting Oct 24 '11 at 13:09
add comment

I've updated my question with more details.

It seems that the only solution for now is to reinstall Windows.

share|improve this answer
    
Why not rewrite the entire page while you're at it, Tom. –  o01 Nov 14 '11 at 10:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.