Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Excel file with Unicode content of which some cells contain text inside double quotes, for example "text".

When I save the Excel file in Unicode format, the text which contains the double quote is saved as three double quotes, for example """text""".

There are some places where I even have text which contains comma (,). For example, text, which is converted into "text," in the Unicode file. It is adding double quotes to the text, which I guess contains special characters.

How can I avoid this?

share|improve this question

4 Answers 4

This is standard behavior (and similar to the way CSV files are saved). See the RFC 4180 – Common Format and MIME Type for Comma-Separated Values (CSV) Files:

If double-quotes are used to enclose fields, then a double-quote appearing inside a field must be escaped by preceding it with another double quote.

How does that apply to your case?

  • This means that "Text" must be saved as """Text""", the outer quotes delimiting the field, and the two other quotes are used to escape the actual quotes you used for your text field. Otherwise, "Text" would be just parsed as Text and you would lose your quotes when re-opening the file.

  • Excel chooses to quote Text, as well, because the comma is used as a delimiter in comma separated files, and not enclosing it in quotes would mean that text, is parsed as two fields when you re-open the file.

If you don't want them in your output, consider opening the resulting files in a text editor and removing all the quotes with a simple search-and-replace.

share|improve this answer
    
You mean that there is no other way to solve the issue other than replacing them in text editor. –  karthik Oct 24 '11 at 13:01
    
Not really, since Excel has to do it for compatibility reasons. Maybe it might be possible to come up with a Macro that does a custom export, but I'm no expert on this. –  slhck Oct 24 '11 at 13:09
    
Ok thanks may be i will try to replace it in the coding side. –  karthik Oct 24 '11 at 13:15

Saving to Unicode seemed to add in quotes even when there were no quotes in my string. Here's how I got around it:

Find a string that isn't in your file( I used 'xxx') Before exporting, Find & Replace All quotes with 'xxx' Export your file to txt or csv Open txt files and Find & Replace All quotes with nothing Find & Replace All 'xxx' with quotes

share|improve this answer

I had this problem too. Then, I noticed I was overlooking the Save as type: option "Formatted Text (Space delimited)". You also have to specify the .txt extension, or it will default with a .prn extension. For example, filename.txt instead of just filename. Try it. It works.

share|improve this answer

You can save the file in .prn, then manually change it to .txt.

share|improve this answer
3  
Could you please clarify your answer? –  DanteTheEgregore Oct 22 '13 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.