Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Outlook 2010 no longer orders correctly when ordered by Received date. Older messages appear fine but when ordered by latest date descending the most recent emails do not appear and the Received date is given as None. Outlook is in cached mode. The Exchange Server is Exchange 2003. OWA is working fine and shows all messages no matter how they are ordered. I have attached a screenshot of what you see when you order by Received. Why does ordering by Recieved Date cause a problem in Outlook and how can it be resolved?

The issue began today but System Restore to a date last week has had no effect. screenshot of outlook problem

share|improve this question
1  
I up-voted your question, perhaps that will allow sufficient reputation for you to post a screen shot. –  Ƭᴇcʜιᴇ007 Oct 24 '11 at 15:23
    
Thanks techie007. I'd up-vote your comment .... if only I could –  Rory Oct 24 '11 at 15:30
    
If you move all the "None" marked messages (or the older ones that have a date) to a new sub-folder, do the "Nones" turn into dates? –  Ƭᴇcʜιᴇ007 Oct 24 '11 at 21:45
    
Do the ones with "None" show up as dates if you change the Current View to "Messages with AutoPreview"? –  Ƭᴇcʜιᴇ007 Oct 24 '11 at 21:49
    
Thanks techie007. I didn't try these changes after all. I just rebuilt the ost file. –  Rory Oct 26 '11 at 9:26

3 Answers 3

From "Microsoft At Work":

Outlook 2010 has a great new feature for organizing messages by date and arranging them by Conversation. Using this feature, messages that share the same subject appear as Conversations that can be viewed and expanded or collapsed by clicking the icon to the left of the Subject line. The messages within each Conversation are sorted with the newest message on top. When a new message is received, the entire Conversation moves to the top of your message list, helping to make tracking email threads a snap.

Perhaps this is what you are running into?

Check out "Group or ungroup email messages in your Inbox" from office.microsoft.com for further information on how to adjust the automatic grouping settings.

share|improve this answer
    
Thanks but no, this isn't it. –  Rory Oct 24 '11 at 15:13
up vote 1 down vote accepted

Problem solved: Because OWA was working ok the issue did not seem to be a server issue. I closed Outlook, deleted the ost file (find location in Data Files in Account settings) and opened Outlook again and the issue was resolved. Probably a corrupt ost file was the root cause.

share|improve this answer

I just resolved an issue like this today.
The version is different, but basically in the Arrange By header, it said "date" but when I checked deeper, it was actually sorting by date modified, not date received.
I right clicked the header, selected "Custom" and then changed the Sort option from Modified to Received.
Maybe your issue is similar

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.