Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to turn-on the Windows firewall, I get the error code 0x80070422 which states "Windows Firewall can't change some of your settings." I could not find any solution on Microsoft website.

I was hoping here someone would know the problem or guide me to the right direction.

share|improve this question

migrated from stackoverflow.com Oct 24 '11 at 17:57

This question came from our site for professional and enthusiast programmers.

    
Is the windows firewall service running? –  Kyle Oct 24 '11 at 18:00
add comment

2 Answers

Malware is usually the cause of this, so scan for malware first, see my post in this link

If it is clean of malware or you removed malware follow this procedure next.

Perform the following steps and update the computer:

  1. Click Start, type Notepad in the Start Search box, and then click Notepad in the Programs list.

  2. Copy the following text, and then paste the text into Notepad:

    sc config wuauserv start= auto
    sc config bits start= auto
    sc config DcomLaunch start= auto
    net stop wuauserv
    net start wuauserv
    net stop bits
    net start bits
    net start DcomLaunch
    

    Click File, click Save As, and then type Repair.bat.

  3. In the Save as type box, click All Files (*.*).
  4. In the Save in box, click Desktop, and then click Save.
  5. On the File menu, click Exit.
  6. Right click the Repair.bat file that you saved in step 5, and then click Run as administrator. This action starts the required services. If you are prompted for an administrator password or confirmation, type the password, or click Continue.
  7. Try to install the updates again. If you can install the updates, delete the Repair.bat file. To delete the Repair.bat file, right-click Repair.bat, click Delete, and then click Yes.

Try enabling the firewall after these steps.

Source of Information

share|improve this answer
    
Thank you for the tip but did not work. I also found the article on Microsoft's website and ran the tests. No luck... –  Fawadafr Oct 25 '11 at 19:19
    
Did you scan for malware as suggested in my link? –  Moab Oct 25 '11 at 21:32
add comment

I'm not sure this would help, but you could try: http://support.microsoft.com/kb/947821 as it helped me with a similar issue.

share|improve this answer
    
no did not work. –  Fawadafr Oct 25 '11 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.