Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu setup on a USB, but the problem is I can't choose to boot from USB in BIOS. I can only choose my hard drive, DVD drive and flopy. I have motherboard ASUS P5LD2

share|improve this question

migrated from serverfault.com Oct 24 '11 at 18:14

This question came from our site for system and network administrators.

1  
Probably best suited for SuperUser.com –  DKNUCKLES Oct 24 '11 at 17:59

3 Answers 3

To boot from a USB Drive you need to connect the boot drive, then boot the computer to the BIOS.

Once in the BIOS, go to the "Boot" Tab and select the "Removeable Drives" option, make sure the "1st Drive" is set to the [USB DRIVE]. Then in the "Boot Device Priority" select the [USB DRIVE] as the "1st Boot Device", from there save settings and exit, the computer should boot from the USB assuming the USB drive is bootable.

share|improve this answer

Do you have a pc with UEFI ? if yes in BIOS settings should be something called boot override and form there you can select your usb device. If this doesn't work look in your BIOS settings and enable legacy option.

share|improve this answer

On ASUS P5LD2 your USB drive will (probably) be listed as a hard disk. Under boot options in BIOS there should be "hard drive (boot) priority", go there and move your USB drve to the top of the stack.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.