Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run SimSpark and RCSSServer when I type $ rcsoccersim3d in Terminal this happens:

(SimulationServer) SimControlNode 'AgentControl' registered
(AgentControl) Running in normal mode.
(spark.rb) sparkSetupInput
(spark.rb) using InputSystem 'InputSystemSDL'
/usr/local/bin/rcssserver3d: symbol lookup error: /usr/local/lib/simspark/ undefined symbol: SDL_WasInit
(MonitorServer) WARNING: SimulationServer not found.
rcssmonitor3d, 0.2
Koblenz University.
Copyright (C) 2004, The RoboCup Soccer Server Maintenance Group.

Type '--help' for further information

(spark.rb) sparkSetupRendering
(spark.rb) using OpenGLSystem 'OpenGLSystemSDL'
/usr/local/bin/rcssmonitor3d: symbol lookup error: /usr/local/lib/simspark/ undefined symbol: SDL_Init
kill: 65: No such process

I've installed most of the SDL packages but the problem isn't solved yet.

share|improve this question

migrated from Oct 25 '11 at 2:27

This question came from our site for professional and enthusiast programmers.

Comment these lines out in simspark/plugin/CMakeLists.txt:

# It is problematic under Linux! Will cause segfaults on simspark exit.
#if (WIN32 OR APPLE)
   set(spark_libs kerosin oxygen salt zeitgeist)
#endif (WIN32 OR APPLE)

and build both SimSpark and RCSSServer3D again!

You can use the Rubuntu Robocup Repository as a Ubuntu repository for installing the 2D & 3D soccer simulation server.

share|improve this answer
Thank you, worked well for me. – Drew Noakes Apr 5 '12 at 12:27

I also found some discussion of this issue here:

After upgrading to ubuntu 11.10, the simspark can be compiled, but when run it, error appeared:

./simspark: symbol lookup error: …/lib/simspark/ undefined symbol: SDLInit ./simspark: symbol lookup error: …/lib/simspark/ undefined symbol: SDLWasInit

The problem is that the -lSDL is not passed for some reason. So for a quick fix, edit two files: spark/plugin/openglsyssdl/CMakeList.txt and spark/plugin/inputsdl/CMakeList.txt, add SDL in target_link_libraries.

share|improve this answer

You must log in to answer this question.