Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running DD-WRT and not being able to reach my public WAN IP from any device on my LAN even though it's visible from outside. Is there some switch I'm missing in DD-WRT?

share|improve this question
add comment

3 Answers

I don't have DD-WRT here to give you a full guide on how to enable it, but, this feature is known as "Nat Loopback" and a quick Google shows me that DD-WRT fully supports this.

I am not sure where the option is, but, it will most likely be under NAT/firewall configuration or interface configuration.

share|improve this answer
add comment

Under the "Security" section, "Firewall" subsection, uncheck "Filter WAN NAT Redirection".

According to the docs, enabling this option "prevents hosts on LAN from using WAN address of router to contact servers on the LAN (which have been configured using port redirection)."

enter image description here

share|improve this answer
    
It all makes sense, but it was not checked and whether checked or unchecked, no difference. I found out a bug report which could explain the behavior. –  hleinone Oct 25 '11 at 20:09
add comment
up vote 0 down vote accepted

Adding

insmod ipt_mark
insmod xt_mark
iptables -t mangle -A PREROUTING -i ! `get_wanface` -d `nvram get wan_ipaddr` -j MARK --set-mark 0xd001
iptables -t nat -A POSTROUTING -m mark --mark 0xd001 -j MASQUERADE 

to Administration -> Commands and Save Firewall solved the issue. Discussed in more detail here and the bug report here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.