Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The necessary information
OS X Lion (10.7) running a VM of Windows 7. Tried both VirtualBox and Parallels and the problem is 100% the same between them.
Require a VPN connection to work from Windows machine. VPN is PPTP type.

Locations
- Home, Time Capsule for a router
- In-Laws, Unknown brand
- Mothers, 2Wire router

Problem
At the In-laws and my Mothers house the VM will not recognize the internet when using a Bridged network connection. It connects to the network, but tells me that there is "No Internet Connection". Caveat, 99.99% of the time this is true but occasionally for no reason that I can discern, the network is recognized and connects to the internet. If it connects, the VPN works flawlessly until I put the VM or the Host (OS X) to sleep or reboot.
If I switch to using a Shared Network (NAT) the internet works fine on the VM, but I cannot connect to the VPN. It gets to "Verifying Username and Password" and never goes farther. I have seen explanations online that this is ALWAYS true of a PPTP VPN on a VM, but I don't know if that is true.

At my house, it works perfect in the VM using Bridged Networking.

I might be able to get control over the routers at the in-laws and my mom's house, but not sure. Mainly I want to know what the problem is and whether I can fix it without accessing the router for the simple fact of possibly working from coffee-houses or libraries. If home is the only place my VPN will work then I can't really be mobile easily.

share|improve this question
    
Perhaps you can use this as a way to get out of visiting parents & in-laws. Just a thought! –  uSlackr Oct 28 '11 at 14:59

2 Answers 2

Any chance that you are using a wired network at home and a wireless network while away? if so, you may need to change the VBOX network setting to connect to the correct NIC.

Another possibility is that your vm guest isn't renewing its address on the new network and the network address is invalid or in use on the other networks. Try releasing/renewing the DHCP addr.

share|improve this answer
    
Nope. Wireless everywhere. –  James P. Wright Oct 25 '11 at 21:45
    
I added another idea above –  uSlackr Oct 27 '11 at 14:19
    
I thought it might have something to do with the address as well, and have done countless release and renews. I THINK that occasionally when it decides to work it's because of that, but it happens probably 1 in 50 tries so there is obviously something else going on as well. –  James P. Wright Oct 27 '11 at 23:12

Bridged connections and wireless links tend to be problematic - not that they can't be made to work (as you have shown at home), they just tend to have strange issues for a WIDE variety of reasons. Bottom line: Bridging directly to a wireless network isn't ideal. When possible NAT is better to use on wireless links.

The other problem you face (and have noted), according to the VirtualBox manual, chapter 6 on limitations of their NAT engine:

Protocols such as GRE are unsupported:

Protocols other than TCP and UDP are not supported. This means some VPN products (e.g. PPTP from Microsoft) cannot be used. There are other VPN products which use simply TCP and UDP.

So what are you supposed to do? Well, what are the chances of switching to an SSL VPN technology? The SSL VPN would give you the least amount of grief over a NAT'd network - and it is part of the standard MS VPN stack now - it is often referred to as Secure Socket Tunneling Protocol (SSTP). I believe it was introduced with Windows Server 2008, and the client is present in both Windows Vista and 7.

If that isn't a possibility, I would start by attacking the routers - the NAT engine in the stock firmware of many routers is really buggy when it comes to PPTP, so upgrade the firmware if one is available. Look into other options as well like DD-WRT/OpenWRT/Tomato

share|improve this answer
    
That very quote you posted is what made me realize that going down the NAT route wasn't possible for me. Not sure if I can convince our network admin to switch to SSTP just for me but who knows. –  James P. Wright Oct 27 '11 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.