Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using my Acer Aspire 5750 at school my wireless connection speed will drop from around 4 Mbps to .30 Mbps. The speed will start out fine from startup and degrade over time. This happens only at school, and only on this laptop using this wireless card. My home network hold its 3Mbps down just fine.

My campus has two wireless networks, one is WPA enterprise encrypted and one is open, both exhibit this behavior. Using my network credentials on another machine or using a different wireless card this machine works fine.

I've updated to the latest driver and rolled back to previous ones. No help.

This is happening on a fresh install of Windows and on Ubuntu live CD so it is not malware or something along those lines.

Spoofing a different Mac address does not change this behavior.

The devid is PCI\VEN_14E4&DEV_4358&SUBSYS_E040105B&REV_00

It is a Broadcom Wireless N...

What could be causing this problem? Does the NIC not like the access points or vice verse? Are they any settings I should tweak? The drop in speed happens no more than 10 minutes after boot and occurs in both Windows and Ubuntu.

I should add that other students don't have this issue so it is not a network wide thing. Other students get around 4mbps down continuously. Using somebody elses credentials on this machine doesn't help either.

share|improve this question
    
Have you asked the network folks there? It's possible they might know if there's some specific reason this would be happening (some hardware-specific oddity). It almost certainly has to be a problem with your hardware communicating with their hardware, though - maybe one side or the other needs a firmware update? –  Shinrai Oct 25 '11 at 22:54
    
Since I didn't purchase a school laptop I'm not eligible to get support beyond getting connected. –  ElvisFanTCB Oct 25 '11 at 23:14
    
How are you measuring the speed exactly? –  David Schwartz Oct 25 '11 at 23:40
    
Measuring speed using speedtest.net and other tests that run in the browser. They all give more or less the same result. –  ElvisFanTCB Oct 25 '11 at 23:53
    
@ElvisFanTCB - That's a load of garbage, right there, I'm sorry to hear if they're that hamfisted. They should at least be able to answer inquiries about the nature of the network (I really suggest asking more as eliminating some rare-but-repeated issue...they might be like "Oh, we've had complaints with similar machines") –  Shinrai Oct 26 '11 at 14:14

1 Answer 1

You may turn off power save mode:

  1. Start
  2. Control Panel
  3. System
  4. Hardware
  5. Device Manager
  6. Expand the Network Adapters
  7. Right click on the wireless network adapter
  8. Properties
  9. Advanced tab
  10. Select Power Save Mode (on left)
  11. Set to Off (on right)
  12. Press OK

Source: http://apevere.blogspot.com/2009/01/acer-aspire-one-slow-wifi.html

share|improve this answer
    
There is no such option in device manager for this card, I've played around with similar settings in there and no dice. –  ElvisFanTCB Oct 25 '11 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.