Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7: I have the Browse folders option set to "Open each folder in the same window" in the Folder Options dialog. Double-clicking folders opens a new window. Please, make it stop.

share|improve this question
    
I have discovered that right-clicking and selecting "Open" on the context menu will open the selected folder in the same window. I have no idea why double-clicking and right-clicking would behave differently, but it may be a clue. –  John Mo Sep 9 '09 at 3:18

4 Answers 4

up vote 5 down vote accepted

I had the same problem. Re-registering two dll's and rebooting solved it:

regsvr32 "%SystemRoot%\System32\actxprxy.dll"
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

I discovered the solution here: http://www.davidmoore.info/2009/08/19/solution-explorer-open-each-folder-in-same-window-error-and-sql-management-studio-ie-and-team-explorer-errors/

share|improve this answer
    
I saw the linked article last week and have just had a good opportunity to reboot. Thanks. Be sure to "run as administrator" to do this. –  John Mo Nov 5 '09 at 14:35

On Windows 7 Ultimate 64-bit, registering the DLLs mentioned in the accepted answer didn't work. Instead I had to run the System File Checker from a Command Prompt:

sfc /scannow
share|improve this answer

I'm having the same problem on the machine I'm at, but it doesn't happen on other machines I've used in the past. You inspired me to try something just now

In folder options, choose file types. find the "(NONE) Folder" item and click on Advanced set the default action to open (was yours set to explore like mine?). That didn't work, but I did notice it's opening up in new window when the folders pane is visible, and otherwise in its own window - does that match your behaviour?

share|improve this answer
    
File Types isn't part of the Windows 7 Folder Options dialog box. –  John Mo Oct 21 '09 at 14:16

if it is not due to virus then go to folder option, general, browse folders, click on radio button (open each button in same window)... It's for windows 7

share|improve this answer
    
OP states 'I have the Browse folders option set to "Open each folder in the same window" in the Folder Options dialog.' so your answer does not seem to address the issue, hence -1 I'm afraid. –  pnuts Nov 29 '12 at 14:22

protected by studiohack Mar 14 '11 at 22:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.