Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

These screenshots are taken from the exact same (binary identical) video file opened in the exact same version of VLC (1.11) on two different machines. Both machines run Win7, and even though one is 64-bit, the VLC binary is 32-bit in both cases.

In other words, there are no significant differences that I can find. And yet, one of these is much less saturated than the other:

image1         image2

What can I do to stop VLC desaturating my videos like this?

P.S. As pointed out in the comments, one PC has an AMD card and the other is NVIDIA.

share|improve this question
1  
How does the capture works? i know NVIDIA and AMD display cards are having different Gamma/color setting for videos by default... –  Tommy Oct 26 '11 at 10:36
    
@Tommy I used PrintScreen. I'll try capturing using some other mechanism. –  romkyns Oct 26 '11 at 10:49

2 Answers 2

up vote 2 down vote accepted

If the settings in VLC are identical there should be no big difference in what VLC does, thus it seems probable that the difference in video hardware is generating different results. I don't have a very solid answer for you, but I would compare the output of another player to see if the same effect is visible.

If another player also yields differing output, the likely culprit is video card configuration (a lot of the video processing is done in video hardware so the settings may matter). If you're not familiar, I'm referring to something like:

some nVidia configuration page

If another video player yields identical output on both machines it may still be the settings I referred to (VLC may use hardware acceleration in places where another player does not).

Let me just leave you with a list of experiments that may narrow down on the cause:

  • Try a different player to see if it is indeed VLC code
  • Try a different video with similar frames to see if yours is a special case or not
  • Try transcoding to different codecs (some may not have hardware acceleration)
share|improve this answer
    
+1, I'm quite confident the issue here is that one is using different hardware acceleration, which could do anything to the video. –  Brad Dec 1 '11 at 20:08
    
Different players produced the same desaturation, as you suggest. I have recently traced this to a Speed/Stamina switch on my laptop, which changes between integrated Intel graphics and an nVidia chip, so you're spot on! (the desaturated variant is on nVidia) –  romkyns Dec 1 '11 at 20:12
    
Yaaay! I feel like a real doctor now. –  Vasiliy Sharapov Dec 1 '11 at 20:17

I have the same issue.

Windows Media-player shows normal video. VLC shows desaturated/brightened video.

That's because VLC always uses NVIDIA settings, Media-player doesn't.

I can force Media-player to use NVIDIA settings also, but than it looks just the same as VLC.

I have not found an option to force VLC to stop using NVIDIA settings, but you can fix the NVIDIA setting to make it look like Media-player, by going to "NVIDIA Control Panel -> Adjust video color settings -> Advanced -> Dynamic Range" and setting it to "Full (0-255)"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.