Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed ubuntu dual boot on an external drive, now I can only boot using the hard drive. Even in my boot says it first searches for my usual boot location, but it still gives me an error while booting if the hard drive is not connected to my computer. This is very annoying.

Is there any way that I can fix this?

share|improve this question

migrated from stackoverflow.com Oct 26 '11 at 15:21

This question came from our site for professional and enthusiast programmers.

    
You can fix this by asking on Superuser.com or askubuntu.com –  Nasreddine Oct 26 '11 at 15:21
    
Change the boot priority in BIOS. –  Aki Oct 26 '11 at 15:27
    
I already tried that. –  Hidde Oct 26 '11 at 15:51
add comment

2 Answers 2

up vote 1 down vote accepted

While installing ubuntu, there is a high possibility GRUB was setup on the computer's internal hard drive. Grub requires some files to load properly and in this case, these files would be on the external hard drive.

I would recommend re-installing the basic windows MBR on the computer's hard drive and then re-setup GRUB on the external hard-drive. You can then configure your bios to first boot on the external hard drive. If connected, it will properly load GRUB, otherwise will fall back to the internal one.

Edit:

You can reinstall the MBR if windows still boot by opening a shell and typing:

bootsect /nt60 C:/

The instructions are usually for computers no longer booting at all.

share|improve this answer
    
Thank you for your response, I can still boot my pc so I don't want to make a recovery DVD. Is there any way that I can access my bootsect.exe file without making a DVD? –  Hidde Oct 26 '11 at 16:03
    
Yes, bootsect.exe is there if you can still boot in windows. Windows XP used fdisk /mbr –  Martin Samson Oct 26 '11 at 21:30
add comment

What other OS are you dual booting with? You'll need a boot loader to switch - which i imagine you're already using. Something like grub should do it if not...

The bootloader will be looking for filesystem info from the external drive, obviously without it connected it won't be able to find any, so it's any additional flags or options within the specific bootloader to tell it that the filesystem is removeable. You might even have to have some basic system files on your non-removeable disk so it partially boots before continuing further from the removeable.

My experience is only basic when it comes to removeable drives - I have a backup server running Ubuntu with a removeable drive, but it doesn't dual boot. :)

share|improve this answer
    
I'm using Windows 7 as my primary OS. Somehow Ubuntu told my BIOS to search for its bootloader on the external drive, and throw an error when it's not found, instead of then booting from my internal disk (where the BIOS too is on). –  Hidde Oct 26 '11 at 15:51
    
Martin's suggestion below sounds exactly like what your comment says is happening - you'll need to remove grub from your internal (windows) drive's boot partition, install it on the removeable drive and then change your 'Boot Sequence'/Order in the BIOS so it looks for the removeable drive before the Internal. :) –  HaydnWVN Oct 26 '11 at 15:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.