Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless network at home which seems to work fine on most computers, however one of my laptops has problems and will take the wireless network down in some situations.

Just to give you some more information on the setup:

  • BT Home Hub 3 Wireless Router (was originally using Home Hub 2)
  • LG R2N1 NAS (The one with 2 drive slots and DVDRW)
  • 2 Laptops (There are more but usually only 2 are on at any given time unless friends are round)

The NAS is connected directly into the router, and everything else is wireless, it is secured and I have tried changing the channels, even used a wifi channel scanner on my phone to find the most open channel to use.

My laptop is a Samsung (cant remember model number off top of my head, but its 13" and of the newer shape, the big brother of the dual core atom netbook, only got it a few months back), this is the one which has the problems. Windows 7, drivers up to date, anti virus and spyware installed and updated.

The other laptop that is frequently used is my other one which is the netbook version mentioned above, with the curves on the back. That has no problems and works fine, also has anti virus and spyware apps, and windows 7 starter.

A guaranteed way to break the routers wireless via laptop

If I navigate to the NAS (mapped as my N:/) and select anything to copy over, could be a 1mb file, or a 2gb file, or a collection inbetween. It will get about 5% in, then just halt. If I cancel it then the network usually stays up, but if I leave it for over 30 seconds, normally the wireless goes down at the router and disconnects everyone in the house, then I get the message that the file has failed and the N:/ can no longer be connected to.

When copying files over, the speed will fluctuate, and on occasion it will tell me it cant find the N:/ but the network will still be active, then about 2 minutes later it will find it again, same problem.

To get the network running again I need to go and reset the router, sometimes I will also need to disable and re-enable my laptops wireless, which then takes about 2 minutes to connect back up.

This problem will manifest regardless of how I am copying, be it through windows, ftp, it also seems to affect me downloading from external websites, which go EXTREMELY slow and dont usually take out the router, but will often fail even after 10%. Websites are occasionally slow to navigate, but that is the case with alot of people.

Things I have tried to fix the problem

  • Checking for viruses etc
  • Updating drivers
  • Reinstalling Windows
  • Turning wireless card off for >1 min then back on (a couple of times this has fixed the problem for a short peroid)
  • Turning off bluetooth (I believe in this laptop the bluetooth and wireless share same hardware)
  • Changing router settings (channel, security, removing old devices from its cache)
  • DNS Clearing and all other command line network related network cache cleanups
  • Changing windows wireless settings to optimize speeds
  • Factory reset router (this seemed to work for a short period, then reverted to same problems on network)

None of the above have any effect, other than the odd occasions I have turned the wireless off and back on again, or the one time I factory reset the router. The first time I did this and it worked I thought I had fixed it, but unfortunately not, a couple of hours later it displayed symptoms again.

Some interesting bits of information

I often use my laptop with my Android phone for internet usage as I am often out and about and need an internet connection, when doing this I connect through wifi to the phone, the internet seems slightly more stable on this connection, maybe not as fast, but doesnt randomly crash out when downloading, which makes me think the wireless card isnt entirely to blame if it works fine on other networks.

If I look in the BT Home hubs web dashboard and go to the advanced settings and look at the connection information there are LOADS of Errors (I am away from the home network at the moment but it is something like 300/1256492366, and I did a few rough tests resetting the router and checking the levels and they seemed to go up ALOT faster if I do something major on the network with the problem laptop.

I have a PS3 and Xbox on the network as well, Xbox is RJ45 PS3 is wifi, they are rarely on and have no correlation to the problem, however I can watch high definition video files from the NAS on the PS3 over wireless without problems and for a long period. So the wireless network itself seems quite stable with all other devices, just not with the laptop.

The laptop reports that it is connected to the wireless using N and usually says around 65mb transfer speed, I have going back to G and still no difference, the router is about waist height in the lounge near a window and the signal strength is excellent on everything.

I am happy to answer any questions and try any recommendations, I am getting fibre installed next week so will get a new BT router, so hoping that the problem may sort itself out, but I ideally dont want to send my laptop back as I need it for work and it seems fine on every other network, just not the home one :(

== EDIT ==

Updated to show that I now have a BT HomeHub 3, and it also has same problems. I have also downloaded a demo of CommView and set the working laptop to monitor my network and then started copying a file.

Some interesting things came out of this, monitoring the wireless channel.

The MOMENT I started copying the amount of packets with the retry flag set started to rocket up, from 0 to over 5000 in roughly 30 seconds. No ICV or CRC errors are recorded though, so I am not sure why it needs to keep retrying.

Also some other details:

Signal - -91/-34/-11 Rate - 0.5/7.75/24

Not sure what the above means but if you are looking at this maybe you do :)

share|improve this question
    
Have you tried to change the channel the wireless is on? What sort of wireless card does the laptop that has the problem have exactly? I had a problem with my own wireless network when somebody moved in downstairs apartment. I was forced to purchase a router with both 2.4GHZ and 5GHZ in order to defeat the interfence problem. Most wireless N routers that do not have this capability only support the 2.4GHZ which tons of cordless phone sold in the last decade use. Today most new cordless phones use a frequency past 5GHZ I do believe –  Ramhound Oct 27 '11 at 12:10
    
Broadcom 802.11n is apprently the model in device manager. As i say above I have tried changing to all channels at some time or another. Currently I think I am on channel 7, I set it back to auto as it made no difference. I live in a little village, and although there are 2 or 3 wireless routers within distance the houses are fairly spaced out, I live in a detached house so I doubt there is any interfearence, also the rest of the wireless network is fine it is just when this laptop tries to do anything on it, but as I also said it works fine on other networks. –  Grofit Oct 27 '11 at 19:04
    
I have now got my BT Homehub 3 and have connected it up. Same issue but it takes longer to occur, I started copying 500mb worth of files, about 100. It would do about 3 files and stop for about 30 seconds, then do 3 more then pause again and so on. After about 60 or so it just said it cannot connect to the device, then after clicking try again it bombed. The network stayed online however my laptop disconnected itself, after turning wireless off and back on it reconnected. The speed on the copy dialog is fluctuating between 900KB/second and 1MB/second so I dont know why it would have troubles. –  Grofit Oct 28 '11 at 20:33

1 Answer 1

up vote 2 down vote accepted

RIGHT! Problem is fixed, although there are 2 levels of the fix...

A friend of mine came round over the weekend and he hammered away at the settings and things. We noticed that whenever I copied the network chart was just bobbing up and down, which was the spikes when it would copy something for a few moments then stop.

After tinkering around he found a setting I had overlooked within the devices properties (within device manager) where there was an option called "Bluetooth Collaboration", after disabling this the network became 10x more stable instantly. However this was still not as stable as the other laptop on the network, as it was not copying as fast, but it was at least copying without bombing out.

This is where the 2nd level of the fix comes in, if you do not use your bluetooth TURN IT OFF at the hardware level. As soon as we did this it became rock solid and just as fast, if not faster and more stable than the other laptop on the network.

I do use my bluetooth so I turn it off when I know I wont need it, and then only turn it on when I do. There is roughtly a 1/4 speed drop when turning bluetooth back on, but it is still fast and stable enough for me.

Previously I had turned bluetooth off at the hardware level but had not changed the driver to not collaborate, which is why it made no difference.

Anyway hope this helps other people who have problems with their network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.