Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to stream an H.264 encoded elementary stream wrapped in RTP headers to a port using FFMPEG.

I have tried the following command lines to no avail...

ffmpeg -i 1080p_1.h264 -f rtp -vcodec libx264 rtp://localhost:4000

and get the following error:

Output file #0 does not contain any stream

I also tried:

ffmpeg -i 1080p_1.h264 -f rtp -vcodec copy rtp://localhost:4000

with the same error.

If I do a conversion with WinFF it seems to work, and the Elecard Stream Analyzer seems to indicate SPS and PPS NAL Units for stream #0.

share|improve this question
    
Can FFMPEG even work on such raw Annex B streams? What conversion with WinFF are you doing? –  slhck Oct 27 '11 at 15:32
    
re: ...what conversion? the WMV preset –  Steve Mead Oct 29 '11 at 14:40
    
It's the same error as this, but there's no answer to:( stackoverflow.com/questions/12007882/ffmpeg-rtp-streaming-error –  SEARAS Nov 10 '12 at 10:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.