Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally, I find Youtube videos that have only one audio channel (only left or only right); example video (left channel only).

This is quite annoying, especially with headphones on, as I hear sound in one ear, and no sound in the other.

So, I want to be able to easily force dual mono (Left+Left or Right+Right) when I find that kind of video, and switch to normal stereo after I finish watching it.

  • I have my headphones plugged well / I don't create audio/video - I want it for real-time playback only,
  • In Windows audio config, setting balance 100% to Left / Right doesn't help (I have either still only left when moved to left, and no sound at all when moved to right), I've checked all the configurations in Control Panel > Sounds and Audio Devices > Audio > Sound Playback > Advanced like suggested in this post, in conjunction with moving balance left/right, and it doesn't seem to have any impact on actual sound I hear in headphones,
  • No need to mix L with R, I just want L+L or R+R,
  • I prefer software solutions to buying a stereo-to-mono adapter,
  • Free solutions please, no $$$ ones, neither trials etc.,
  • In Control Panel > Realtek HD Sound Effect Manager I can turn on various mumbo-jumbo effects like: Concert Hall / Hangar / Bathroom / whatever environment (and in fact it makes the sound appear in two ears, but well, it's ridiculous to do this;), but there is no Dual Mono option.

  • Finally, I know I can force L+L or R+R in VLC Player which supports Youtube (well, a little hack is needed, because Youtube internals change from time to time) but it is not very convenient to launch VLC just to play Youtube video - I want to keep it in the browser, I use Firefox generally (but well, if I don't find easier way, I will launch it in VLC).

share|improve this question
    
Does it make a difference when you set the speaker setup to "Laptop mono speakers" in this screen: worldwide.bose.com/productsupport/assets/images/articles/… (Control Panel -> Sounds and Audio Devices)? –  Stefan Seidel May 6 '13 at 8:14
    
@StefanSeidel no change. –  jakub.g May 6 '13 at 20:07
    
Downvote their video and leave a comment telling them to fix their audio mix in the future. –  Nick T Dec 4 '13 at 22:12

6 Answers 6

Here is a simple foolproof way to resolve that.

  1. Right click on in task bar.
  2. Right click on active audio device and click on
  3. Click on tab
  4. In the tab, in the drop down menu choose <1 channel, 16 bit,....>
  5. Click

Done

Change it back when you are done :-)

share|improve this answer

When having the same problem, I use 2 programs.

The first one is Soundflower. You can do some routing with that, but it's not as practically as one would like. The important thing is that it creates a virtual input and output interface. So you can direct the output of your system to this virtual inout and then reroute it back to your interface. In order to do that, I use LineIn. This programs has the feature of selecting the routing of each channel (left and right) for the input AND the output. You can simply route the active channel to both left(1) and right(2) channels.

I am not sure I explained it so well, so here it goes again:

  • Install Soundflower & LineIn.
  • Soundflower creates a virtual Interface (actually 2 but anyway), which you can choose as system output. But of course if you do it, without rerouting the Soundflower out, you won't hear a thing.
  • You launch LineIn and you choose Soundflower as input and your physical interface as output. If you press "Pass Thru" then you hear the same thing (only one channel). That's solved easily: You click "Advanced" and under Input Device Settings, you choose Left Channel:1, if the video only has left or 2 otherwise. Then you choose the same for the Right channel. You click Ok and then Pass Thru.
  • You got it! You have the same audio in both channels.
share|improve this answer

Right click on sound volume in taskbar, playback devices.

Right click on active audio device.

Properties -> Levels

Balance, set left / right till it sounds ok.


Remember to reset after the one video, or you'll then be deaf in that ear.

share|improve this answer

A 2 dollar jack splitter solved this problem for me.

enter image description here

share|improve this answer
    
I have one, still no change for me (maybe I have a wrong type, don't know). –  jakub.g May 8 '13 at 10:02
up vote 8 down vote accepted

I just accidentally found a lame and hacky but working way to solve the issue - plug the headphones halfway, instead of fully, to the port :)

share|improve this answer
    
Clever, easy out-of-the-box-thinking solution. Took 1/2 second to implement, now I can enjoy the video instead of it driving me crazy :) –  Daryn Feb 12 '14 at 22:39
    
After an hour of fiddling with various jack adaptors and looking around audio settings, this solved not only this issue but my issue with my computer in general only having one speaker (the left). Now both channels come through the one speaker. Bravo! –  TenLeftFingers May 21 at 21:17

I have a solution for you but this is a paid software

This software might will be a sure fix: http://www.fxsound.com/dfx/index.php

I've used the software for a year now and has made my audio experience with my headphones waaaaaaaaay better. I'd say it's worth the 30$. Don't use this on games though, there's a configurable delay on the sound but the minimum delay you can get is 10ms and you might get clicking issues with that delay.

I just tested the video you are referring to without and with DFX and it do apply the sound in both channels.

Just turn 3D surround on and the sound will play on both left and right

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.