Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why doesn't Ctrl+Right Arrow work in SecureCRT? How can I make it working?

share|improve this question

migrated from stackoverflow.com Oct 28 '11 at 1:54

This question came from our site for professional and enthusiast programmers.

1 Answer 1

First put in ~/.inputrc:

"\777": backward-word
"\002": forward-word

Then click SecureCRT menu "Option/Session options", go to Terminal/Emulation/Mapped keys in the left, click "map a key..." button in the right, press "ctrl-left arrow", in "Map selected key" dialog, select "Send string" in left and input "\777" in the right "Send string" box. Do it again for "Ctrl-right arrow", except that you input "\002".

You can choose other strings to be sent than "\777" and "\002". If so, be sure to modify both in .inputrc and "send strings".

Now you can use 'ctrl-arrows' to skip words in console.

EDIT: '\001' will disable 'ctrl-A' (move to the beginning of the line).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.