Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The DVD drive on my HP Pavilion a1509in (Intel P4) is not working. To install any OS I have to use my USB drive.

In the BIOS boot options menu it shows only:

Floppy disk
CD/DVD drive
Hard disk drive

I've checked everywhere in the advanced setup menus to see how to enable a USB boot option but I can't find anything. Any ideas?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

After many workarounds on my PC I just found the another way to boot from a USB disk drive, using some open source tools:

  • Install Easy BCD.
  • Add the Eacy BCD BIOS extender entry to the boot menu.
  • The Easy BCD BIOS extender menu redirects to plop boot manager if you choose the boot option during boot up.
  • Now you have the option to boot from a USB disk drive as shown below:

    enter image description here

This will be helpful for many old computers which do not support USB boot in their BIOS.

share|improve this answer
    
Ah, I guess we were assuming you didn't currently have a bootable OS. +1 –  Paul Nov 24 '11 at 4:42

I am pretty sure that model doesn't support USB boot. You might want to try upgrading the BIOS to see if it helps, but the latest bios dates back to 2007 and doesn't suggest it provides this feature.

The USB drive might appear as a disk, so if there is an F button you can press during bootup to select a boot device you may be able to see it.

HP Drivers Page

share|improve this answer
    
Thank you very much –  Desingh Oct 28 '11 at 3:05
    
@peter Is there anyway to trick my Floppy drive boot option as a USB drive ? –  Desingh Oct 28 '11 at 3:09
    
No. I think your best bet would be a new IDE cdrom drive –  Paul Oct 28 '11 at 3:26

I ran into the same thing. frustrated I was searching around for answers...but I figured it out.

the usb drive is listed under the HD not removable drives.

selected the HD option, then moved the USB to the top

made sure it was first in the boot option

rebooted and whola!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.