Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just updated to Ubuntu 11.10 and I am using unity 2d. My terminal applications (gnome-terminal or konsole) just won't go into background. When I move another application in front of them, they are still rendered, but the clicks are going through them. This behavior only appears when the terminal windows interact with another applications. I can move one terminal over another without a problem, but even the menu list of a terminal application can not be shown, since it is - for some unknown reason - "behind" the terminal.

Any ideas what might be the cause of this problem?

I do not have this problem with my other machines. The only difference is, that I am using unity 2d here and ("normal") unity at home.

share|improve this question

2 Answers 2

I had the same problem, and, in fact, this very same page led me to the solution. I did not create and xorg.config file though. I solved through gconf-editor.

Open the terminal and type: gconf-editor /apps/metacity/general

look for the compositing_manager options and uncheck it. Your windows will flicker and the problem will be solved.

One thing to have in mind is that you will not have transparencies any more. For example, your launcher will not be semi-tranparent.

Personally I prefer to use gconf-editor because it gives me a sense of safety.

share|improve this answer

If you haven't seen it, a workaround is provided as part of the discussion in the Ubuntu forums:

I solved the problem by creating a /etc/X11/xorg.conf file containing:

Section "Extensions"
Option     "Composite"    "Disable"
EndSection 

The limitation is that disabling the composite extension also disables the Ubuntu 3d desktop.

I'd still be interested in a patch / workaround that also supports the 3d desktop since I switch between them – time to submit my first bug report.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.