Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to use PuTTY behind a Proxy, but every time I try to access PuTTY, I get a black window with one green square and not able to input any kind of data...

enter image description hereenter image description here

What do I need to do to get access to my server using PuTTY? I can connect with my iPad, so no issues connecting to the server...

EDIT:
This is what my netstat looks like:
enter image description here

share|improve this question
    
You HTTP proxy must have the connect command enabled to use non-http protocols. –  billc.cn Oct 28 '11 at 13:31
    
Do I get you right. It works with your iPad over the same proxy? –  gabe Oct 28 '11 at 13:36
    
@gabe, no, my iPad is using the 3G connection, so no Proxy. –  Michiel Oct 28 '11 at 13:41
    
@billc.cn, what do you mean? –  Michiel Oct 28 '11 at 13:41
    
A HTTP proxy by default can only relay http traffic. However, an extension in the standard (the CONNECT verb) allows the proxy server to connect to arbitrary port with arbitrary protocol. Because there's a risk that this connect feature is misused, it's not enabled on all HTTP proxies. You have to check with your admin if connect is allowed or ask for a SOCKS proxy. –  billc.cn Oct 28 '11 at 15:22

2 Answers 2

up vote 1 down vote accepted

This is most likely not the answer you want, but if your network admin has correctly configured the proxy, then you can't connect through it.

I am guessing they don't want to allow non-http(s) traffic, so there won't be much you can do about it. You could try running your ssh server on port 80 or port 443 and see if they allow you to connect to it that way.

share|improve this answer
    
Indeed. I checked with our IT-department. They don't allow non-http traffic. Too bad! –  Michiel Oct 29 '11 at 12:10

I assume you are sure about the HTTP Proxy Setting and the Port

If not try with 8080 and the ip address instead of the dns name of the proxy

It could be a problem with putty not using the proxy you need to

  1. Load your saved session
  2. Set the Proxy
  3. Save your session
share|improve this answer
    
It's the proxy address used by Google Chrome and predefined by the system settings (it's a companies laptop). I get an error if I do what you said... Proxy-error: Unable to resolve proxy host name –  Michiel Oct 28 '11 at 13:29
    
often proxies have port 8080 are you sure its 80? –  gabe Oct 28 '11 at 13:34
    
mine is 8080. But even with this setting configured, I get an the same error... –  Michiel Oct 28 '11 at 13:42
    
I added some additional information. Maybe it will help –  Michiel Oct 28 '11 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.