Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using google earth on a Linux. I need to go through a proxy to get to the internet so I start google-earth like this

export http_proxy=http://myproxy
google-earth

And it works fine. However, I need need to pull a KML file from a server on an internal network that I cannot access through this proxy. This example is similar. When I then open the KML file that says 'pull from this server,' google-earth cannot find the server. If I start google-earth without setting http_proxy I can access the server but not the internet (so I can't pull google-earth data)

From what I've found I can't tell google-earth when to use the proxy selectively. The only solution I can think of is to forward a port that isn't 80, however I would like to avoid this if possible.

EDIT: It seems that google-earth ignores the no_proxy environmental variable.

share|improve this question

This should do the trick.

export no_proxy=localhost,127.0.0.0/8,10.0.0.0/8,172.16.0.0/12,192.168.0.0/16

Add whatever you need to the no proxy export line.

Disclaimer - I'm not sure if Google Earth respects the no_proxy variable or not.

share|improve this answer
    
it doesn't, how obnoxious. – devin Oct 28 '11 at 21:01
    
Sorry - certain apps need to have something added to their config files in order to do exclusions. I'm not familiar enough with Google Earth to be of much more help. – Tim Brigham Oct 28 '11 at 21:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .