Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two identical Asus EeePC netbooks that are both installed with Ubuntu. One of them was sitting on the closet shelf and the battery went completely dead. When I charged the battery and tried to boot the it, I got the "No init found" error. In trying to follow the suggested way to fix it posted here, I used the Startup Disk Creator on my Ubuntu 11.10 desktop machine to create a USB stick with a bootable Ubuntu 11.10 live CD on it (the netbook doesn't have a CD drive).

I plugged the USB stick into the netbook with the init issues, went into the BIOS and selected the USB stick as the 1st choice to boot from, and did a hard restart. It then just stuck at the flashing underscore. Not knowing why it wasn't working, I tried booting my working netbook from the USB stick. When I got into the BIOS on the working netbook, I noticed the description in the boot order section for the USB device was different.

On the non-working netbook, the description was SWISSBIT (the name of the USB stick) but on the working netbook it was just "Rem. Drive". I also noticed on the working netbook there was an additional option under the bootable order section that allowed me to choose which hard drive to boot from. This section showed two hard drives, one of them being my USB stick. So, rather than changing the device boot order, I selected the USB stick as the hard drive to boot from first and it worked like a champ - I was able to boot into the LiveCD on the USB stick.

Seems to me the working netbook is seeing the LiveCD USB stick as a hard drive, where-as the non-working netbook is seeing it as a plain ol' USB stick. The BIOS is the exact same version on both netbooks... any idea why it works on one and not on the other?

share|improve this question
    
Well, oddly enough, I just kept rebooting the machine and entering the BIOS settings (F2) over and over again and finally after about the 20th time or so my USB LiveCD showed up as a hard drive rather than a plain ol' USB stick. Not sure what the deal was... I'm going to leave the question unanswered for a while to see if anyone knows what was actually going on. –  Bryan Oct 29 '11 at 15:32
    
I was struggling with this and found I had to hold down F2 while I powered on, but then was able to get into the bios. –  Amanda Apr 30 '12 at 18:21
    
I once experienced similar behaviour with a damaged USB port. Wonder how to test tough. –  bdecaf Jul 17 '12 at 11:09

1 Answer 1

up vote 2 down vote accepted

The Asus computers have an interesting feature to allow boot device selection without entering into the BIOS setup screen. When you just power up your computer, first of all, you will see a gray screen showing the Asus logo. While on this screen, press the ESC key and the computer will show you a blue screen with a list of bootable devices.

Steps to follow:

  • Power off your computer (the one having problems to boot from USB)
  • Plug the USB device on one USB port. Try to choose one direct USB port instead of one port connected to an internal USB hub. If you do not know which one to choose, use the same as you used on the netbook which was able to boot from USB.
  • Power on the netbook
  • Hit the ESC key.
  • The USB device should appear as a possible boot device. Select it
  • If everything was right, your computer should be booting from the live USB device.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.