Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My wife's windows 7 is dead (sony vaio VPCEA3L1E). It cannot even allow the recovery console or safe mode. When the computer starts, it tries to boot windows and stops at a lovely blue screen. I can see the cursor and move around, however there's no logon prompt. F8 does not seem to work either. Here're the things I tried in order:

  1. Plugged the windows 7 disk to my mac but I couldn't mount the partition with data. I can only access the Sony partition with the
  2. Used F10 at boot time. It's Sony way of reinstalling the system from the recovery partition. It shows me the screen saying something like "please wait Sony recovery is loading..." but it never ends.
  3. Try to boot from windows 7 DVD disk but it does not help either. It freezes after first installer wizard screen.
  4. Tried the ultimate boot cd. TestDisk says filesystem is broken on the partition but cannot do much more about it
  5. Tried live ubuntu bootable from CD. I tried mounting with -f, but it still yields error:

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error Failed to read of MFT, mft=6 count=1 br=-1: Input/output error Failed to open inode FILE_Bitmap: Input/output error Failed to mount '/dev/sda3': Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

So currently I'm trying to boot the laptop in a way I can run chkdsk /f. So far the boot cds I found didn't help.

Generally, I cannot give the hdd to the service because my wife is afraid we'll lose some pictures of our 5-month daughter. Hence recovery of the data is of the essence :)

share|improve this question

migrated from serverfault.com Oct 29 '11 at 7:13

This question came from our site for professional system and network administrators.

    
You've been fairly thorough, but there may be a few more things you can try. Firstly, I would suggest (trying) to backup your partition - you may have some success with Todo Backup - it has linux/WinPE disks (and may be able to check/fix the partition or at least create an image you can test elsewhere); or try using dd. As for making headway on fixing things try: booting up a WinPE (e.g. BartPE) disk and running chkdsk from there; ntfsresize from linux (you don't have to mount the device). You may also have some luck with GPartEd. –  cyberx86 Oct 29 '11 at 6:10
    
Try Spinrite6 at level 2...grc.com/intro.htm –  Moab Oct 30 '11 at 3:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.