Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This drives me crazy.

The worst is when I type in a text box on a web page, and since I'm used to a PC keyboard, hit Home when editing and the browser goes back and everything is lost.

This happens across all browsers I've tested - Firefox, Google Chrome and Safari.

I've tried changing the mapping using DefaultKeyBinding.dict, but it works for some apps only.

share|improve this question

1 Answer 1

Try redefining the Home/End keys to do what you want them to do.

If you open the Keyboard Preferences and navigate to the Keyboard Shortcuts pane, you will see see "Application Shortcuts" in the list on the left. (It has the old AppleWorks "A" icon.) When you select it, you'll see a list in the right-hand section. Make sure you have selected "All Applications" and then click the "+" to add a new short cut. Follow the prompts to redefine your Home/End keys....

Let us know if that worked for you. (I'd test it first, but I don't have a dedicated Home/End key)

share|improve this answer
    
Hi David, unfortunately this doesn't solve the problem - I have already tried, if I assign Home key to some other action, it will navigate back and then execute the other actions. –  Bojan Bjelic Nov 4 '11 at 23:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.