Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a Clear Chat PC Logitech headset. Its possibly the best headset I've ever had, and it wasn't cheap. So you can imagine my disappointment when I upgraded to a 64Bit OS , only to find out - the sound is choppy, but it works fine in 32Bit OS (win 7 RTM in both cases).

Logitech won't help me solve the problem, and I doubt if MS will. Is there any way I can fix this problem without relying on the "giants".

Any ideas would really help.

The device uses the standard USB Audio Driver supplied by Microsoft. Not sure if its a driver issue or a general USB issue.

share|improve this question
    
I hope there is a resolution to this. I have that same headset and will be installing W7 64bit as soon as it comes out. –  Zooks64 Sep 3 '09 at 19:48
    
Gadzooks - its already out - if you have MSDN or technet subscription. So when I'm talking about Win7, I've installed the real thing (retail final) not some Beta or RC. And I can confirm - Go 64Bit dude... problem solved! –  JL. Sep 4 '09 at 6:35
add comment

1 Answer

up vote 1 down vote accepted

This is what I have discovered after 4 days of day and night searching for this solution....

GUYS I HAVE THE ANSWER (Hope it works for you too).

Firstly it has nothing to do with 32bit or 64Bit. I figured this out, installing 2 clean systems, and installing drivers 1 by one, and software, checking everything.

I was also worried that it could be motherboard drivers, or even possibly an out of date BIOS, if you can obviously update your chipset drivers, and try get a BIOS update.

But still this didn't solve the problem....

Here is what finally addressed the issue for me....

!!!THE GRAPHICS DRIVER!!! I know its hard to believe but I'm using a laptop so I got my driver from laptopvideo2go.com , instead of the latest, I rolled back to an earlier driver.

Now everything works like it should....

share|improve this answer
    
That is the strangest fix I have heard of to an audio problem :) –  alex Sep 4 '09 at 9:21
    
Counter Intuitive, but I figured it out, since, after installing graphics driver and enabling aero, things went side ways.... with the right driver, you can enable Aero and have no problems... –  JL. Sep 4 '09 at 11:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.