Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install mercurial in my Fedora 14 using yum and get the following error.help to resolve this.

 yum --enablerepo=rpmforge --disablerepo=remi --disablerepo=fedora  install     mercurial.i386
 Loaded plugins: langpacks, presto, refresh-packagekit
 Adding en_US to language list
 Repository fedora is listed more than once in the configuration
 Repository updates is listed more than once in the configuration
 Setting up Install Process
 Resolving Dependencies
 --> Running transaction check
 ---> Package mercurial.i386 0:1.9.2-1.el5.rf set to be installed
 --> Processing Dependency: python(abi) = 2.4 for package: mercurial-1.9.2-1.el5.rf.i386
 --> Finished Dependency Resolution
 Error: Package: mercurial-1.9.2-1.el5.rf.i386 (rpmforge)
       Requires: python(abi) = 2.4
       Installed: python-2.7-8.fc14.1.i686 (@fedora/$releasever)
           python(abi) = 2.7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Remove the RPMForge repository data permanently. You should not be using a EL repo on a Feroda machine. Please mind the bitness of your operating system, i686 means 32-bit. If you have a problem then log a bug in RH's Bugzilla requesting a version upgrade to the packages in the repository.

share|improve this answer
    
You mean disablerepo? –  itsraja Oct 30 '11 at 2:51
    
No, I mean remove it permanently. You should not be using a EL repo on a Fedora machine. –  Ignacio Vazquez-Abrams Oct 30 '11 at 2:52
    
I've removed, but while yum list 'mercurial' , I end up some .i686 only. mine is 32 bit –  itsraja Oct 30 '11 at 2:58
    
i686 is 32-bit. –  Ignacio Vazquez-Abrams Oct 30 '11 at 2:59
    
ya am sorry, but I found 1.9 versions of mercurial in their website as source. But the listed ones are 1.8, how to get the latest ones or should I install and update later –  itsraja Oct 30 '11 at 3:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.