Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently able to scan to email using aspmx.l.google.com on port 25. Everything I've read about the 8890DW talks about SSL, but nowhere does it say anything specific. When trying to connect to gmail.smtp.com on port 465 I simply get a configuration error. Tried 587 as well. Also tried google.smtp.com with the same results. I can scan and email to any gmail address, but that's pretty limiting.

Any suggestions would be terrific!

EDIT: In the config, there is input for SMTP AUTHORIZATION with port, username and password, but nothing specifically for SSL. I guess I assumed with SMTP AUTH it would automatically use SSL or TLS but that doesn't seem to be the case.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

The server is smtp.gmail.com, not gmail.smtp.com.

It's possible that the device automatically enables TLS for port 465, or when it sees a STARTTLS offer over 25/587.

If not, you could set up a computer on your network to run a SSL proxy – stunnel – which would make SSL unnecessary on the 8890DW.

share|improve this answer
    
My mistake. Was typing on my phone and must have gotten a bit dyslexic. Thanks, I'll look into stunnel, but I'd prefer it worked the way it was supposed to, am I wrong? –  Mark Oct 31 '11 at 1:43
1  
As this post has been viewed over 2500 times, I thought I'd leave an update. I've been using stunnel since @grawity suggested it and haven't had any trouble whatsoever. Initially I had stunnel running on a Windows 7 machine on the LAN. Currently it's running on a Linux box. Thanks @grawity! And thanks @Daniel for the jumpstart on stunnel.conf. –  Mark May 27 '13 at 23:42

Brother multifunction devices do not support TLS / SSL connections.

As grawity suggested, you can use stunnel. It ensures that email credentials as well as the content of your message are encrypted at least up to and within Google's platform. Here's our stunnel.conf:

[SMTP Gmail]
client=yes
accept = 0.0.0.0:25
connect = smtp.gmail.com:465

This instructs stunnel to accept incoming connections on port TCP 25 and forward them through an SSL tunnel to Google's SMTP servers on port TCP 465. The 0.0.0.0 is shorthand notation for all avialable IPv4 interfaces. 'client=yes' tells stunnel to operate as an SSL client rather than a server.

Be sure to open a pinhole on your proxy machine's firewall for port 25. Then point your Brother multifunction printer to the address of the machine running stunnel.

If your Internet connection uses a static IP address (or is very stable), you can skip encryption and fallback to plain SMTP. Simply use aspmx.l.google.com as the SMTP server address with port TCP 25.

You'll have to add your gateway IP address to the Email Whitelist box in your Google Apps control panel. Finally, if you have an SPF record for your domain, you'll need to adjust it accordingly to include your gateway IP address as a legitimate sender:

v=spf1 ip4:123.45.67.89 include:_spf.google.com ~all

If you don't know your gateway IP address, check dnsstuff.com (listed in the upper left hand corner).

http://support.google.com/a/bin/answer.py?hl=en&answer=176600

share|improve this answer

My Issue was trying to set up the Fax to send all the faxes to an email address instead of printing them. If you contact Brother Tech support for the MFC-8890DW they will tell you it does not support SSL. Below is what I did, step by step, and it is working for me.

This must be done though the ControlCenter3 software that comes with the printer. I downloaded mine off of their website. In Windows 7 it will appear in the Start menu under the Brother folder.

You will need an email account for the fax machine with password. I used a Yahoo bizmail email.

ControlCenter3 Under Device Settings go to Remote Setup. The default password is access. Enter your settings in Network -> E-mail/iFax -> Setup Server Under Auth. for SMTP pick SMTP-AUTH Enter the machine's email address under Network -> E-mail/iFax -> Mail Address Apply and Exit ControlCenter3

In Internet Explorer go to the machine's IP. Under Fax Settings -> Remote Fax Options pick Fax Forward and email address.

To Test Network Configuration -> Configure Protocol -> POP3/SMTP -> Click Submit Enter your email address and check "Send test E-mail" Click Submit

If this isn't working and faxes are backing up in the fax memory you can get them to print. Go to the fax and enter the menu. Press 2 (fax) 5 (Remote Fax Opt) 3 (Print Fax) Start.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.