Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It used to be when I plugged in my digital camera, it would mount and I'd see a link on my desktop. For some reason, now it no longer does this. When I plug in the camera, it does absolutely nothing at all. If I open up iPhoto, I can see the device and copy photos but I absolutely hate iPhoto and just like to copy files off the device manually. Is there some setting somewhere that allows me to configure this behavior? I'm running OS/X Lion.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

When you connect an imaging device like a digital camera or a scanner to a Mac, it will not show up on the desktop. Only cameras that act as mass storage devices are actually mounted and shown on the desktop, just like other volumes.

So I guess you'd have to change a setting in the camera (e.g. a "transfer mode" vs. "mass storage" mode).

Either way, Image Capture.app can be used to transfer photos, so you don't need iTunes for it. They might have changed it in Lion, but you can even set it to automatically open when you connect your camera.

enter image description here

share|improve this answer

Your Finder Preferences may not be set to show External disks. If that's the case, the mounted volumes won't appear by default on your desktop.

  • From the Finder menu, choose Preferences...
  • In the General pane, there is a Show these items on the Desktop section.
  • Make sure there is a check next to External disks.

If there is a card or disk inserted, it should appear as soon as the box is checked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.