Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So here's the problem: I've got this Asus p7p55-m motherboard that was originally purchased with 4Gs of memory and it all worked well until I wanted to drop extra memory in it (KVR1333D3N9K2 model). So I purchased another 4G of the same memory and bios will show 4g of usable memory and Win7 (x64) will show 8G installed (4G usable). Perhaps, someone can suggest something on this eh?

Initially the memory was located in A1 and B1 slots:

A1 A2 B1 B2

so I added the extra ones into A2 and B2 respectively and then tried swapping everything the was that old memory was sitting in A1 and A2 and new ones in B1 and B2 neither seemed to work out.

Here are a few screenshots in case this may be helpful.

motherboard info

memory info

bank 1

bank 2

bank 3

bank 4

Thanks all for any advises.

share|improve this question
Yep, that is odd. The memory timings look the same, your motherboard claims to support up to 16GB. The only thing different is the part number on the memory stick and I wouldn't expect that to be a problem. – Mokubai Oct 30 '11 at 19:52
What is your processor out of curiosity? Since your memory is no longer actually controlled by your motherboard (though the motherboard does matter) you may want to check how much memory your processor supports. – Mokubai Oct 30 '11 at 19:56
@Mokubai thanks for looking into this - indeed I'd expect this to kind of work out :) I'm worried the memory is running in single mode (it's KVR1333D3N9K2 model). The processor is Intel i7 870 Lynnfield. – abolotnov Oct 30 '11 at 20:08
Both the CPU's datasheet and the motherboard's qualified vendor list indicate that your new memory modules are supported, so this is really a mistery. What is the model of your old RAM? – Oct 30 '11 at 21:09 same model, mate. – abolotnov Oct 30 '11 at 21:28
up vote 2 down vote accepted

So I upgraded the BIOS to its latest revision and kept swapping the memory around and at the end of all I have the 8Gigs now. Not sure what exactly has helped, it could be that I haven't firmly pushed the chips in or something (but if that - how did CPU-Z detect all my memory). Anyhow, this is considered solved.

share|improve this answer
As you have solved your problem you should be able to mark you answer as correct. – Mokubai Nov 5 '11 at 23:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .