Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since Firefox 7 (or 6?) they silently removed "http" from the address bar. Previously, when you clicked it, "http" showed up again, allowing to easily just change http into https.

So far, I found two ways to get it back, but isn't there a setting I can use to have it permanently in vision again, or at least when I click it?

  • Way 1: copy selection and paste it again
  • Way 2: type the whole scheme again in front of the address
  • ...
share|improve this question

2 Answers 2

up vote 2 down vote accepted

From the mozillazine forum:

Type about:config in Location (address) bar filter for browser.urlbar.trimURLs right-click or double-left-click and Toggle this to false

The http:// should then show up again.

oh and setting the browser.urlbar.formatting.enabled preference as false may be of interest also.

share|improve this answer
    
Those settings don't both hide-during-view and show-when-edit (Opera behavior), but I don't see other settings that can do this, so I guess it's either all or nothing here. –  Abel Oct 31 '11 at 10:56

With a recent update, the autocomplete changed so that if you make a request on http and then change the request to https (but leave everything else unchanged), it changes it back to http. Similar thing happens if you first make the request on https and then change to http.

At first I got around this by adding something random like "?0" at the end of the url, but I found out that disabling browser.urlbar.autocomplete.enabled in the config also fixed the problem.

EDIT: As several people have pointed out, this is not really a solution as such. It just shows that it's new "awesome bar" features that have introduced the problem :) (the adding meaningless http arguments to the address bar might be a long term solution, if you don't have to do it too often).

share|improve this answer
    
Quite a drastic workaround as it kills quite some features, but thanks for sharing. –  Abel Jul 19 '12 at 15:54
    
Indeed. The awesome bar is the best thing about Firefox (that about about:config), so I hope this will get fixed at some point. I would have submitted a bug report, but it seems a lot of work :P –  Svend Hansen Jul 23 '12 at 9:01
    
I have the same problem, but I don't want to disable the URL bar autocompletion. See superuser.com/q/503411/151741 –  unor Nov 10 '12 at 6:01
    
It doesn't seem to happen to me any more... I guess it has been fixed at some point with a later update... –  Svend Hansen Mar 13 '13 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.