Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason my search in Windows 7 start menu has stopped displaying results from the Programs menu. Any program that was installed that put shortcuts under Start Menu >> Programs used to show up in the results at the top, however now none do and instead only files with similar names appear.

I forced Windows 7 to rebuild the file index for my entire drive, but that didn't fix the problem.

How can I fix this?

share|improve this question
up vote 2 down vote accepted

First, right-click on the start menu orb, go to Properties, Start Menu tab, and click the Customize button. Scroll down and make sure that "Search programs and Control Panel" is checked. You can also ensure that the one just above that, "Search other files and libraries", is set to "Search with public folders".

This can still be a problem of Programs not being indexed. See the following articles :
Improve Windows searches using the index: frequently asked questions
Microsoft's Open the Search and Indexing troubleshooter

See also if this hotfix applies to your problem : The "Search programs and files" box does not display search results correctly in Windows 7. If it does, you will see a "Hotfix download available" section at the top.
For more info see Fix Windows 7 Start Menu Search Problem.

share|improve this answer
    
I checked into all of these but nothing helped. I notice that a few programs show up but not all of them. Also control panel items show up. – void.pointer Nov 9 '11 at 16:56
  1. Press the Windows logo key + R on your keyboard.
  2. In the Run box, type regedit and then press Enter.
  3. User Account Control permission: If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.
  4. Locate the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}  
    
  5. Right-click this subkey, and then select Delete.

  6. Restart the computer.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.