Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get the External Editor extension for thunderbird to work, so that I can use Emacs to compose emails. I haven't had much luck in getting this to work. Can anyone describe the steps they used to make this work. I think that my first problem is that the external editor plugin itself is not working, as I cannot even get it to work with gedit.

http://globs.org/download.php

Running:

  • Ubuntu 11.10
  • Emacs 23
  • Not sure which version of External Editor to use
  • The latest Thunderbird from the main repositories
share|improve this question
    
you should supply some more information (operating system, thunderbird version, etc.). External Editor 1.0.0 is working fine for me with thunderbird 8 and emacs 23. – mgalgs Dec 1 '11 at 2:20
    
@mitch_feaster I just added that information. Thanks – stevejb Dec 1 '11 at 8:38
    
did you actually install External Editor? If so, did you set up your external editor in the add-on preferences? If you want help you need to tell us exactly what you've already done and exactly what's not working (error messages, etc). – mgalgs Dec 1 '11 at 17:02
    
I'm on icedove (aka thunderbird) 10.0.4, Debian testing, and could not get it to work. I tried Emacs23 (both /usr/bin/emacs and /usr/bin/emacsclient) as well as Emacs24 (/usr/bin/emacs-snapshot), but trying to open the external editor via the Tools menu is always a no-op. No error message, just nothing. – Eugene Beresovsky Jun 27 '12 at 1:50

In the external editor settings (Tools, Add-ons, Extensions, External Editor Preferences), make sure to put in the path to emacs where it says "Text Editor". I'm doing this on OS X, so here's what it says for me:

/Applications/Emacs.app/Contents/MacOS/Emacs

You would want to put in the location of your emacs executable: likely something like:

/usr/bin/emacs.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .