Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Only occasionally I have to open a Visual Studio project with a VS instance running under admin. This is a little inconvenient because I can't use the short-cut for that project in the VS Jump List. How can I modify the Jump List entry to force VS to open that project running as admin? Please note that I'm not trying to avoid providing admin auth to do this. I'm just trying to avoid having to run VS as admin, and then having to open the project from within VS once it opens.

share|improve this question

2 Answers 2

You don't need to modify the Jump List entry. Just hold down Ctrl + Shift keys while clicking on the short-cut, it will be opened with admin privilege

share|improve this answer
    
This does not work =[ –  Relequestual Feb 20 '12 at 15:42

I have the same problem, but your solution doesn't seem to work. When I press Ctrl+Shift+Click, the just list closes and nothing else happens (VS isn't launched)

I found a different solution though it's not exactly what I would hope for: You can set VS to always launch as administrator, which also works when you invoke it from the jump list. To do so:

  1. Right click on the VS shortcut->Properties->Open File Location
  2. Right click on devenv.exe->Properties. In the "Compatability" tab mark the checkbox "Run this program as administrator"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.