Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I do:

svn ci filename

and get:

svn: Commit failed (details follow):
svn: Authorization failed

Why don't I get a prompt for username and password?

Details: I am the administrator of the project on sourceforge. I did svn checkout without problems. Doing this didn't help, too: svn ci -m '' --username=myusername. Again, this username is the admin of the project. On Windows I can commit by using ssh dsa.

share|improve this question
    
Thanks a lot, this answer was of great help. Although I had to svn co svn+ssh://myname@repository_url – user178256 Dec 5 '12 at 17:35

The problem was solved by doing checkout again, this time from a svn+ssh://url instead of svn://url. (I tried svd sw --relocate unsuccesfully)

share|improve this answer

Needed me hours to fix it.. Open View 'SVN Repositories' under "Windows/Show View/Other" in the View, open the Project Right-click: 'Location Properties' Under URL change the 'svn://' to 'svn+ssh.//', like cyporg mentioned Finish, give login, and it should work again, without new checkout :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .