Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was looking around for a utility that emulates the Windows 7 effect of Win + a number key to activate an application from the position on the TaskBar matching the number.

Spotlight, Quicksilver all work well, but (in rapid-fire work sessions) sometimes I just want to use one blind keystroke to activate an application.

EDIT

Tried adding an application launcher service then assigned keyboard shortcuts to it but to no avail: enter image description here

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Without the need for third party applications, you can bind launching of any application to a keyboard shortcut using Services.

Open Automator.app, create a new Service.

Set it to receive no input, and from the Library, drag "Launch Application" to the editing panel. Select which application you want to launch.

For example, I used Preview.app.

enter image description here

Save it under any name you want. Now, go to System Preferences » Keyboard » Keyboard Shortcuts » Services. Find your new Service under General and enter the keyboard shortcut you want to launch the application with.

For example, -1.

enter image description here

Be careful though: Most applications override keyboard shortcuts with ⌘ and numbers, since they have special meanings. For example, in applications using tabs, this will select the first one. In Eclipse, this opens the quick fix menu, et cetera.

To change Services you already created, go to Library/Services.

share|improve this answer
    
thanks for your answer, I followed your steps but the shortcut doesn't launch the app, i thought maybe it's a conflicted shortcut so i tried a few others that involved many more modifiers just so to avoid any conflict but to no avail. Does your method work on your computer? My mac is new, just got it 3 days ago so... –  Nik Nov 1 '11 at 21:52
    
@Nik I always try the answers I post, so, yes, it worked for me. When you Run your service in Automator, does your application launch? –  slhck Nov 1 '11 at 21:53
    
@Nik I don't think ⌥⇧1 is a valid shortcut. I wasn't able to use it as well. Can you try ⌥ ⌘⇧1? –  slhck Nov 1 '11 at 22:00
    
thanks for writing back again. The run command in Automator does summon chrome. I first tried cmd+1 and it didn't work. –  Nik Nov 2 '11 at 2:32
1  
it works with the ⌥ ⌘⇧1 and now it also works for ⌘1!! At a glance, it would be some mistake, but I just came back from dinner, tried your two suggestion and not another thing is changed on the computer. I hope it has nothing to do with keyremap4mac (not that I swap any of the modifier keys with it) strange anyways, thanks! solved! –  Nik Nov 2 '11 at 2:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.