Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Synergy on Red Hat Linux 5.4 but I'm getting the below errors:

rpm -ivh synergy-1.3.8-Linux-x86_64.rpm
error: Failed dependencies:
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by synergy-1.3.8-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4.14)(64bit) is needed by synergy-1.3.8-1.x86_64
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by synergy-1.3.8-1.x86_64

I have a Red Hat CD with me which may contain these dependencies but I'm not sure how to install them. I do not have a license for Red Hat, so I cannot use Red Hat support.

I tried creating a repo file which points to /media DVD and tried to use yum install synergy directly but that didn't work either.

If the CD doesn't contain these dependencies, what other options are available for me?

share|improve this question
    
Why are you using RHEL if you don't have a license? You do have other options. –  Ignacio Vazquez-Abrams Nov 2 '11 at 4:49
    
I want to try out on Red Hat only since I've everything setup on my red hat & I don't want to switch to another OS for now. –  Mike Nov 2 '11 at 4:51
    
Not having access to the repos will significantly cut down what you can try. –  Ignacio Vazquez-Abrams Nov 2 '11 at 4:53
    
You can use the Fedora repositories. –  new123456 Nov 2 '11 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.