Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having terrible trouble with packet loss and latency with my USB wireless adapter for a while. No other computer on the network has this problem so I updated drivers and I reinstalled windows and still the problem persisted.
Finally I noticed that unplugging my USB HDDs resolved the problem. I felt this was rather odd as the packet loss and latency happened even when the hard disks weren't active

Is this to be expected? Is this an unavoidable consequence of having a large number of USB devices? Is there anything I can do about it?

I have:
Windows 7 x64 Enterprise
Edimax EW-7711UAn wireless adapter
4 External hard disks

share|improve this question
    
Do you have to unplug all of the HDDs or is unplugging one or two sufficient to get the wifi to work? Just wondering if this is a power issue. –  Tog Nov 2 '11 at 11:35
    
I haven't tried plugging in different numbers/combinations of hard disks as I've only just figured this out and, as it's an intermittent issue, it would be hard to draw conclusive results. But I suspect it's not a power issue as all the hard disks have their own power supplies and I tried the wireless adapter on an molex-powered usb3 add-in card with no success. –  Toukakoukan Nov 2 '11 at 11:53
1  
Do you have a USB extension lead? If electrical noise is causing the problem, maybe moving the adapter away from the disks/PSUs would help. –  Tog Nov 2 '11 at 13:37
    
I shall try that and get back to you! I have to say interference has been a problem in this area/configuration, I've been forced to stop using my wireless mouse for this reason... –  Toukakoukan Nov 2 '11 at 15:51
add comment

2 Answers

up vote 0 down vote accepted

Do you have a USB extension lead? If electrical noise is causing the problem, moving the adapter away from the disks/PSUs would help.

share|improve this answer
add comment

As Tog suggested above - it is probably a power issue, a possible 'fix' would be to use one of the rear ports if you're using a front port, or get an external powered USB hub... Another (probably better) solution would be a PCI(-e) USB card for additional USB ports - as it would also have a totally new controller as part of the card.

share|improve this answer
    
as I've said in my reply to Tog, I have a separate pci-e USB card, which had no bearing on the problem, unfortunately. –  Toukakoukan Nov 2 '11 at 15:44
    
Then (again as mentioned above) cable interference would be a cause, especially if the adaptors powering your external disk's (or any other adaptors) are near to the USB cables. I've seen mobile phone chargers cause data corruption on external drives. :) –  HaydnWVN Nov 2 '11 at 15:57
    
Yeah, I think this may be the case. –  Toukakoukan Nov 2 '11 at 16:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.